Pasting issue

When I create a new lesson, I have to mess around toggling the plain-text button several times before I can paste text. Usually the text comes in unformatted, I assume what your program thinks is “plain text”, which is not what I want. I should be able to copy paste without thinking about it, but about a month ago you guys changed something. Please change it back.

@Wulfgar - The lesson page doesn’t support custom formatting such as bold, italics, etc. and the new Import Lesson page defaults to stripping this additional formatting code from the text that you paste in. Would you give me an example of the kind of text you are trying to import?

I’m not talking about those things. I’m talking about having separate paragraphs, indentation and such. Use any text with indentation, and it takes several toggles to get it to paste at all, and normally comes in as one solid block of text. The difficulty of pasting text started about a month ago.

@Wulfgar - Yes, I just wonder if you would be able to send me some text that you’re trying to import. I’m curious to see the formatting in the text you are importing to see if it’s related to the specific text or an issue with our text field. A direct link to the text would be great if possible!

Try to paste any chapter. It pastes with no problem in the description, but with great difficulty in the text box. It’s too bad this was changed.

Have you tried CTRL V?
It works well for me.
Or the import bookmarklet; it also imports like the original.

@Wulfgar - Seems to work fine for me as well. In Safari, you can go to “Edit → Paste and Match Style” when pasting the text in. That should hopefully work properly if it is still giving you issues.

@mfr - Yes I’ve tried CTRL V, and right click paste.
@alex - that works, thanks. I want you guys to know that I don’t have to do this for the other boxes (title, description, etc) if I want to paste into them. Did you recently add the little undo/redo/paste as text buttons in the Text box? Why does this box have to be different from the others?

@Wulfgar - The text field was recently updated to automatically remove additional HTML formatting from text when pasting it in. It seems to still be causing some issues in Safari when using Ctrl+V, and I’ve passed this along to our development team.

@alex - When I uploaded a lesson yesterday, I noticed the form had changed, so I tried copy/paste again. Instead of dense text, this time it came in on every other line. I was too lazy to go back and see if “paste and match style” works; I’ll do that next time. But I wanted to let you know it looks like the issue has changed.

I copy/pasted a lesson today and it worked, without “paste and match style”. The only strange thing is the text pasted into the window with grey shading. The lesson came out fine though.

@Wulfgar - we are still working on some minor issues here. Anyway, it is good to know that the lesson comes out fine. Thanks!

Unfortunately, it’s back to the every-other-line issue, whether or not I use “paste and match style”. But maybe that has to do with the format of the original. Also, the new form has some issues in safari - the course name not showing up in it’s entirety, for example.

@Wulfgar - sorry to hear you are still having trouble with this. We are still working on the Import page, however, the text field should be working properly now. I have tried to paste text from a few various websites. It looks fine for me. Would you be able to make a screenshot to show how it looks for you? Just to test, please try pasting text from one more different source to see if that changes.

The title seems to be partly hidden for me too, when it is quite long. We will look into it.

I had the same problem with imported text coming out as dense text and not preserving the original format. But I’ve just been back to the lesson in question ( added 6 April), deleted the text and re-pasted in again and now it comes out fine. I didn’t use the ‘paste and match style’ in Safari just the paste command. So it seems what ever was the problem is fixed now.