Netflix Imports Failing w/"No appropriate captions found"

I tried posting in another user’s thread, but think my comments got overlooked. I get “no appropriate captions found” when trying to import from Netflix. Yes, subtitles are enabled in the target language before attempting the import. I’ve tried multiple Netflix shows in Dutch, and one in Italian. All of them give the same error message after a long pause. I tried importing both to a new playlist and to an existing list. It failed on Chrome 103 with both Windows and Linux, as well as Firefox 102 on Linux. I reinstalled the Chrome plug-in and the Firefox plug-in was installed for the first time. I even tried using it through a VPN while connected to a Belgian server.


Thanks, we are investigating the issue.

Debug info in case they’re having trouble recreating the error:

In particular, 117 failing means that the div with id “LQNFXSUB” isn’t created, and that’s relied upon for extracting the subtitles later on.

document.body.insertBefore(configElem, document.body.firstChild);
is failing because this is running before the body is ready (document.body is null). This likely has to do with a change to sync/async behaviour on Netflix’s side. Before, something was probably blocking the plugin from running until the body was ready. It could also be a race condition, but I’m guessing not.

A company as big as Netflix rolls out changes conservatively, not to everyone at once. That explains why not everyone is affected yet.

Perfect, thanks for this!

Any updates on this?

There’s still an issue with Netflix import from Chrome. It works through Firefox, Edge and Safari. We are looking into finding solution for Chrome extension and we hope to solve it soon.

I’m having the same issue, and there seems to be no solution.

1 Like

Same here:
I tried it with Chrome / Firefox for English, French, Portuguese, and Spanish.

The LingQ plugins don’t seem to work anymore for Netflix…


It seems this has not been resolved yet, I am still getting this error in Chrome.
Also tried Firefox, same error “Error: No appropriate captions found.”
I also tried Safari where the import is said to succeed but it only seems to import the description text and only in English instead of the target language.

Is there a workaround for this problem?

1 Like

We are looking into it and trying to figure out what’s going on. Thanks for your patience.


Ok… have to ask, though: there’s a thread on this forum that’s 3 years old about this problem. Did it break again or has it never worked?

@CyranoSteve It’s a new issue, of course. Netflix import worked properly, but sometimes, due to changes made on Netflix’s end, we have to deal with those changes on our end too to make it work again.

Chrome importer doesn’t work at all for me. Safari one imports only a description (in English…) also adds the movie image to all the other lessons in the folder…

1 Like

It still doesn’t work for me on chrome and firefox, sorry to hear that because that’s why I bought the premium version

In the meantime is there some other way to get the transcripts from netflix until this bug decides to disappear again?


Also experiencing this bug again (in FF and Chrome). The workaround I am using is Tamper Monkey with Chrome and this Script to manually download the VTT file.

As an edit: If you name the VTT the name of your Course in LingQ, it will add it to that Course. Naming won’t be ideal (Subtitles 1,2,3,4…), but it works.


side note: you can use tamper monkey and the disney plus version too since the plugin doesn’t work on that platform anyway

1 Like

Thank you

So if it’s an issue of LingQ having to keep up with netflix updates, do we need to report this every time it happens so that LingQ’s IT can work on it or does LingQ’s team know of this everytime it happens.

I use LingQ for primarily netflix transcripts but I’m fine grinding the flashcards until the importer works again.

Does it work on Amazon prime or HBO max?