Login issue - Android app

Dear all,

Unfortunately, I cannot log in on my Samsung phone. I installed the latest version of the Android app and everytime I try the app says

Could not log in {“non_field_errors”: [“Unable to login with provided credentials.”]}

I checked all my account information and they are right. I also reinstalled the app. Reset my passport. Anything hasn’t worked. However, on my Samsung tablet, there isn’t such a problem. It works fine.

Best regards,


Update: Now it says also sometimes “Could not log in. Connection closed by peer”.

Hmm, I just checked this and it seems to be working properly - it should only report this error when the incorrect username/password combination is entered, and this message actually comes from the server rather than the app. Would you try again and see if it’s still giving you this issue?

Dear Alex,

Thanks for your reply. The problem still exists, I am afraid. I have rechecked my account information again and again, but I can’t log in. Sometimes it says also “Could not login. Connection closed by peer.”

Is maybe a country filter enabled? RIght now, I am in Sudan.

Best regards,


I don’t think it would be a country filter. You mention that it is working on your tablet - is your tablet with you as well and also working?

Yes, I have it here and it works properly. I type the same account name plus passwort on both devices and just my phone makes some problems. On my phone, I cannot log in at all.

In that case it definitely seems to be something specific to the device or the individual installation. Would you try deleting the app on your phone and trying again?

I reinstallied the app now for the second time (I have already tried it once before) and it seems as if it hasn’t fixed the issue. The same error message appears again and again.

I’m really sorry to hear that this is still giving you trouble. I wish the answer was obvious and that there was a simple fix. Our options at the moment are to try to continue collecting information on this.

What is peculiar is that it is working fine on your tablet. I assume this is logging into the same version of the app while on your tablet - correct? If this is the case then it’s very strange, as both the phone and tablet version of the app use the exact same code. The only other distinction I can think of that might affect it is the network that you are connected to. Ensure they are both on the same network, and if one is working and the other still isn’t then I think it is most likely something outside of the LingQ app, though I don’t really have an idea of what that thing would be…

No, there are different versions. On my tablet, there is Version No. 3.1.6 and on my phone there is the latest one.

Also tried different things in the meantime: cleared the data of the Lingq app in the application manager and also reflashed the current firmware of my phone, but anything of it helped. The same error apears again. Both devices are also connected to the same network.

OK, if you update your tablet can you confirm whether the same issue appears? If it does, send me an email and I’ll send you the 3.1.6 version which you can then reinstall and we’ll see if we can find out what in 3.1.7 would have caused this.

So, I updated the version on my tablet as you suggested. At first, I was still logged in and it worked. After I logged off I get the same error on my tablet as well. I will e-mail you in a few minutes so that you can send me the version 3.1.6. Thanks in advance.

Thanks for checking! I’ve noted this down and will be in touch if we need any additional information to figure this one out!

Welcome! And my thanks for the older version. It works again perfectly. Sure, if you need any further information, I will be happy to provide it.