LingQing Known Words Taking Up Reading Enjoyment/Time

I’m a lifetime subscriber of LingQ (Spanish) and I love it. My biggest gripe that has me using an alternate program more is the fact that I can’t simply mark a word as known without first LingQing it so I can track it in the vocab section.

I wish that, similar to Migaku, LingQ had a dictionary to pull definitions from so you could just add that word with one click AND THEN add user definitions if you wanted further clarification. When I’m reading I’d like to just quickly press “known” and move on but I find myself spending more time creating LingQs on a given page than enjoying the content.

Unsure if maybe I’ve been missing some feature or if this simply is the LingQ workflow. Would love to hear if you all care to track your words known in the vocab or not and how you handle LingQing taking up time over the actual reading.


You need to buy one of rooster’s extensions. It allows you to AutoLingQ the whole lesson with one click then you are good to go in normal reading mode. It saves me so much time from lingqing words and from hardly disturbing the flow of reading. Also , his extension uses numbers as shortcuts to mark the words known. Check posts on forum for this.

see the image below:


If you’re working on the web, you could just just use the hotkeys…left/right to cycle through the lingq’s on the page. Mark them as 4 (which I think counts as known) or whatever level you want it at.

Looks like the rooster extension that Asad is showing does that with the one click, as it looks like these are all underlined. On the apps, you would have to click the word, mark as 4. So two clicks unfortunately.

1 Like

Thanks for informing me of this addon! Guess I’ll use this anytime I start reading something and then move to mobile from there

1 Like

Thanks for the info! Unfortunately, I do believe marking as a 4 doesn’t actually add it to your vocab list as you MUST have a definition and THEN mark as a 4

1 Like

@mrfrosty I double checked.

  1. I used arrow keys to get to blue word “Umwege”
  2. Clicked 4 key. This added the LingQ with level 4 and the “top” definition (these all get preloaded when the lesson is opened, even for blue words).

  1. I checked my vocab list in the vocab section. It is there with level 4 and a definition (the top definition). I didn’t select any definition.

So you can go back later and clean up or select a better definition if you want to later. I work in sentence view but this would work fine in normal page view as well (from the website). From the app…you can do the same, just click a number, but that does involve a lot more clicking than the website.

Having said that, asad’s solution sounds quicker, but if you don’t want to use extensions, keyboard shortcuts are very quick too and can easily be done while reading.

1 Like

You could … if the hotkeys worked reliably, but of course they don’t.

The left and right arrows work for a while, then one or the other or both stop working. My impression is that the location of the cursor (or however the program thinks of it) goes into an indeterminate state that it can’t move from. The only hotkey solution is to Shift-Arrow to the previous or next sentence.

The arrow keys may start working again or you may get impatient, close the page and open it again.

I have never seen even freeware where the arrow-keys stopped working.

1 Like

Admittedly I use mostly the app, but have not seen the issue on my occasional usage of the website (I use it maybe every couple of days for parts of a lesson here and there).

I did just try a full lesson in sentence mode using arrow keys and clicking 1 for each blue word and had no issues at all (limited sample size admittedly). Even just the arrow keys got me to the next page. The shift-arrow shortcuts are supposed to move to next page. I do notice when it changes page, no word is highlighted, but next arrow key gets me to next word. Note to anyone doing this approach…make sure to use the sidebar for the vocab as otherwise it pops up a window over the text which is rather annoying.

Maybe it’s a browser specific issue with the shortcuts? I’m using Microsoft Edge mostly or Chrome occasionally.

1 Like

I’m using Brave based on Chrome (or Chromium to be exact). The problem seems partly due to multi-word LingQs which overlap, and probably other cases.

I see this everyday, every session. I’m sure I’m not the only one.

It wouldn’t surprise me if right-arrowing through a virgin lesson would be OK. That’s probably all that LingQ tests with. But a lesson from a multi-lesson course that has already been extensively marked up is likely to be different and certainly is in my experience.


I agree. Making lingQs, choosing the best meaning from a list or writing them is a complete waste of time. It’s the main reason I use LingQ very little these days. You can turn on ‘auto-lingQ’ in the settings, but this only auto-adds the top meaning of the list. It would be better if LingQ had better definitions though, as the top definition isn’t always a quality definition. I’ve brought it up before with LingQ, but it would require a major overhaul and a lot of work to change it for all language combinations, so I don’t expect any change anytime in the next few years, but who knows.

1 Like

I had this problem with lingQ until I realized that shift-arrow always works. Once I learned that I switched to using that, even though it’s less convenient (it takes 2 hands).


Lingq does have an option “move to known when paging” and also when you declare a lesson as finished, the blue words get all moved to known. This one might have an option as well (not sure). The words do get sent to the vocab as known.