LingQ Update and Issues

Hi guys,

I’m having a few issues with creating LingQs at the moment. It sometimes doesn’t allow me to put a space, or press left or right, for example. It will ask if I want to cancel my request to create a LingQ, or it will change tabs in my window, or other strange things. I’m using FF.

As a side note, I’m not a big fan of the dictionary popping up inside the LingQ editor as it moves my page around and distracts me. Others might disagree.

Hmm, sounds strange. Has anyone else noticed issues like this? If it’s switching between tabs then it sounds like it’s an issue with your browser/computer.

The in-frame dictionary might not work as smoothly on smaller screens. You may want to try QuickLingQ View to create your LingQs, then use Standard View to actually read through the text and review.

Ok, I’m still having this issue. I don’t have to deal with it much because I use the hints and Google translations most of the time. I’ve noticed that it does it both at work (IE) and at home (FF).

Basically, I can’t press space bar without it wanting the close the LingQ editor (i.e. “Do you want to save your changes?” or whatever it is). And I can’t press ‘Left’ or ‘Right’ without it trying to leave the box (or the page!).

It doesn’t seem to do it all the time, which led me to believe the problem might have been with my computer. But it does do it on two completely unrelated machines using different operating systems.

Surely someone else is having this problem as well?

I sometimes have some problems similar to this in the import page’s text box. Pressing left or right can make the cursor disappear or backspace will go literally back a page, even though I’ve got the cursor blinking in the text box. Come to think of it, I’ve had issues in the lingq edit box too. Never had it changing pages on me but the cursor disappearing or not moving.

@peter - We’re not able to reproduce this one. Would you be able to use something like Jing (Screen Capture Software | Snagit | TechSmith) to take a screencast of this? That should hopefully give us a better idea of what’s going on.

It doesn’t seem to do it all the time, but it’s been doing it again tonight. Here’s a link. This window came up each time I pressed spacebar in the LingQ editor.

I tried again, but am still uncertain which steps you took to produce this dialogue box. Were you in Firefox when you took this screenshot? Also, have you tried this with other dictionaries?

It’d be especially helpful if you could take a video of this. If you’re worried about not being able to reproduce it, I recommend just setting Jing to record (it goes up to 5 minutes for Free users), then use the site as you normally would. If it happens within 5 minutes, just upload that video and email me the URL along with the time at which it happened.

Geez, Alex. You’re making me work! :slight_smile: I hit spacebar a few extra times at the end so that you could see what it was doing (spacebar, then escape, spacebar, then escape, etc.).

And yes, this is with Firefox.

Sorry, peter. I’m still not able to reproduce this. What would really help is knowing which steps you take to cause this error to begin occurring. I see that the error occurs when you press the space bar, but I imagine it isn’t the case every single time you press the space bar, right?

Is there anything you’re doing different that causes this alert to start popping up? Also, is it the same problem with other dictionaries or just with WordReference? I wonder if having WordReference open in a popup window instead would help at all…

I’ve got no idea. If it’s only me who’s having this issue, then I’ll just suck it up. Maybe it’ll disappear after the next update.

Is anyone else having this issue when trying to save LingQs?

I still get this issue from time to time. I also seem to get it on different computers (not just home and work, but it was happening on a third computer as well).

I’m hoping I’m not the only one…

Using Windows 7 64-bit and Firefox 10.0.2 and working in Spanish.

If I (1) click on a word to make a LingQ, and (2) my next keystroke is the space bar, then (3) the LingQ window jumps upwards on the screen (just as if I had hit Page Down instead of the space bar).

If I (1) click on a word to make a LingQ,and (2) my next keystroke is the Backspace, then (3) the browser goes back a page, as Imyirtseshem reports above.

However, I do not experience the problems Peter has with Left and Right or with the strange behavior that follows his pressing the space bar.

The upshot of this for me is a LingQ with a Phrase but without a Hint. But I can edit the LingQ to type in a hint.

The Left and Right thing doesn’t appear to be the main problem with me. Instead it’s the below (as per the screencast above).

“Basically, I can’t press space bar without it wanting the close the LingQ editor (i.e. “Do you want to save your changes?” or whatever it is).”

@donhamilton - The space button scrolling the page and the backspace button sending you to the previous page are both built in actions in your browser for all sites not just LingQ. However, we have now made it so that the cursor will be centred on the hint field when you open the widget. This means the spacebar and backspace will be aimed at that text field instead of performing those standard actions for “read only” pages. It’s also convenient to have the cursor in the hint field already…

@peter - Sorry, no update on your issue which we still can’t reproduce.

@Mar: Centering the cursor on the hint field is indeed more convenient. Thanks.

@Peter: This is just a very wild stab in the dark, and I really doubt it has any bearing on your problem, but could you possibly have some other program running on all your computers that could be causing interference with LingQ?

@peter About the issue you’re facing, while I’ve been playing around with an addon for Firefox, the javascript in the addon was causing LingQ to act strangely (not exactly the same, but it could be related) - do you have any addons for Firefox that might interact with javascript that’s running on a webpage at all?

@donhamiltontx & Lyise - No idea.

It’s strange, though, that I’m the only one who has had this problem, and that I’ve had it on several different PCs (two IE, one FF).

Right now, as I’m working through a chapter of Vingt mille lieues sous les mers, I’m discovering how painful it is to have to “copy and paste” a “space” from somewhere… lol