LingQ is only importing first or two episodes of series

I find the import feature invaluable but lately it has only imported the first episode and perhaps the second. Later episodes appear to import but when you go to it in LingQ it’s just the earlier episode. I’ve checked and the URL passed to LingQ is correct. This has been happening on An example is Zombie | SVT Play where the first two episodes imported and third didn’t.

Sorry to hear that. Do you have problem importing from that one specific site only? Were you able to import from there properly before?

I’ve seen this too with SVT Play. When you select later episodes in a series it grabs the subtitles from the first episode.

This was an example I’ve tried where I ran into it. I just extracted the subtitles and manually imported them.

I’ve only been using SVT because it has good content. I’ll look around on other sites. Import worked well on two series we watched earlier the month but stopped on the third.

thanks for your prompt reply.