Lesson Playlists via LingQ Web Interface

As of this morning, I seem to be having a problem creating playlists via the web interface. I was able to create playlists fine in the previous few days.

Here’s what I’m doing:
(i) Select Lesson
(ii) From Menu, select “Add to Playlist” option.
(iii) Type in the Name of My Playlist, and select the “Add New” option.
(iv) Click on the “Add” button.
(v) Sometimes (but not always), I see a message stating “Lesson XX added to Playlist YY”.

When I go into “My Lessons” and select the “Show Playlists” options, I only the see the playlists which I had previously created. I don’t see the new lessons which I have created as of this morning.

Am I doing something wrong or is this a new problem with the web site?

Also, I haven"t found any way to synch down to my iPhone (or iPad) the lesson lists which I create via the web site? Is there some way to synch automatically, or do I have to manually recreate each of the playlists manually on my other devices?

@pcolag - I just tested this function and it seems to be working fine for me. That’s strange that you were able to do it previously. All I can suggest is refreshing the page and trying again. You should see a confirmation message every time you add a lesson to a playlist. As far as syncing with the iPhone app, unfortunately, this isn’t possible. It is on our list but, at the moment, those two playlists are quite separate.

Hello Mark and thanks for your response.

I don’t think that this is due to a browser refresh problem. I have tried to create lists on 4 different types of browsers (Firefox, IE, Safari, and Chrome) and I am getting the same behavior on all these different browsers. I also tried on iPad (with Safari) and I am also getting the same behavior.

The one strange thing that I did notice, is that the server seems to “remember” the names of the lists that I have created, because when I start typing the name of the list that I’ve already created previously (i.e., via the “type completion” feature). Since this is occurring across different browsers (i.e., I create a list on one browser and then it becomes “visible” on a different browser), I am assuming this must mean that the backend server has some knowledge of the list that I have created. The identify of the newly created list cannot be passed by one browser to the other, as they do not share any information (e.g., cookies). So the problem that I am running into seems to be that the new reading lists are being created, but that the process of associating lessons to these lists does not seem to be working for me (across several types of browsers and on both Windows and iOS platforms).

Is the system you are using for your tests exactly the same production system that I am accessing via my browser? If so, then do you have any suggestions for what else I can try in order to isolate the source of the problem? Is it possible that the filtering criteria is somehow “hiding” my playlists so that I can’t see them? I did play around with all the filtering criteria but did not have any success, when I set the criteria to include “private lists” all I see are the lists that I successfully created two days ago.

Thanks for your help!

P.S.: Is anyone else experiencing this problem?

@pcolag - when you first create a list it is created. The next time you start typing that lit name it searches existing lists and displays the titles. You don’t need to create a new playlist each time and these work cross browser. Are you perhaps creating slightly different playlists each time? You must type in the list name, select it as it appears and then press the Add button to actually add the lesson to the playlist.

Hello Mark. Yes, I understand that I don’t need to recreate the lists each time. Once the list is created, I use the same name for all the lessons that I want to add to the same list. This is what I have been doing. My problem is that I am no longer able to add any lessons to these newly created playlists. However, for the existing playlists (that I had created a few days ago), I am still able to add lessons with no problems. So, I’m really at a loss as to what is going on… It appears that the behavior of Playlists has changed. Do you have any further suggestions as to how I can add lessons to my newly created Playlists?

Nothing has changed with the playlist functionality. How many playlists have you created? How many work and how many are you unable to add lessons to? This seems to be a strange error so we need to understand how to reproduce it.

Hello Mark. So far, I have created two private playlists which work correctly. I am able to view these playlists within the “My Lessons” view. I am also able to add new lessons to these playlists and everything works fine. In one of the lists I presently have 9 lessons and in the other list I have 17 lessons.

For any other private playlists which I have subsequently created (I tried about 5 different names), I am not able to view these playlists within the “My Lessons” view (I only see the two private playlists which I had previously created). As I mentioned in an earlier post, this behavior is consistent across several browser types (IE, Firefox, Chrome, Safari). It is also consistent across Windows and iOS.

Please let me know whether you need any additional information in order to help reproduce this problem.


Here is another piece of additional information which might be useful in diagnosing the problem. When I got into the “Library” view to search for public (i.e., shared) playlists, I only see 3 different playlists. I don’t know if this is normal but it seems to me to be a low number for the shared playlists.



Mark, I believe I have found the solution to my problem. It seems that Playlists will not display in the “My Lessons” view if there is only a single lesson associated to it (i.e., it will display only if there are 2 or more lessons associated).

In my opinion this is a bug and should be fixed, as it quite be misleading if you are not aware of it (as I wasn’t). However, since there is an easy workaround (i.e., wait until you have at least two lessons to create a new playlist), then the fix is not so urgent.

In my case, I"ve started to use playlists in order to help me manage the growing number of lessons I have (including private imports from conversation reports, writing correction reports, etc…). However, I only had a single lesson for each of these new categories (for now), which is why my Playlists were getting created but were not displaying.

@pcolag - Good catch! I’m not sure why that is. I’m sure we’ve always tested and assumed that you would only create playlists if you have more than one lesson to add to a playlist! :slight_smile: However, we will get this fixed as it is confusing.

@mark - I am now running into a similar problem with private Course that I have created. I can see the courses I have created from the pull down menu when I create a new lesson. However, if I go to the “Imported Lessons” and select the Courses (from the “Show” radio buttons), then I don’t see any courses displayed.

For one of my courses “Conversation Reports”, I know that I have two lessons assigned to it so I’m not clear why I’m not able to see it from the “Courses” view under “Imported Lessons”. Is there anything else that I need to do in order to be able to see my private courses?

@pcolag - Would you be able to tell us what your settings look like on the right hand side of that page? It’s possible that these settings are affecting what displays in the list.

@alex - I assume that you are referring to my filter settings (i.e., on the RHS of the page). Under the extra filters, I have only “New” and “Shared” checked off. Everything else in the “extra filters” is unchecked. With these settings, I can see my Private lessons and Private Playlists, but not the Private Courses. Please let me know if that is the information that you were looking for.

@pcolag - Ah, I misunderstood you. You are on the My Imports page, correct? It should automatically tick the boxes “Private” and “Shared” when you click on the My Imports button. Is it not doing this?

By the way, it looks like there may be a similar issue here where courses with 0 or 1 lesson in them aren’t appearing properly.

@alex - Correct. I am on the My Imports page. However, I misspoke before. You are correct that it is the “Private” and “Shared” boxes which are clicked. Under this configuration, I can see my Lessons and Playlists, but could not see my courses.

However, you are correct about the problem being related to the fact that courses with 0 or 1 lessons do not appear correctly in the list. I went back and checked, and one of my lessons was filed under ‘Conversation Reports’ (not a course, but a grouping structure I assume) . I assumed that this was the same as the Course I created called ‘Conversation Reports’, but it wasn’t. After going back and editing the lesson, I assigned it to the Course entitled ‘Conversation Reports’ and from that point on the Course started displaying correctly. So, I am OK now that I understand the behavior. However, it would be good to eventually fix this issue (same as for the Private Playlists), as it can be confusing if you are not aware and just getting started building up your courses and Playlists.

In terms of making the process of assigning Lessons to Courses easier, I do have a suggestion to make. Why not use the same approach as for adding Lessons to Playlists (i.e., have a “Add to Course” entry in the drop-down menu of the Lesson, analogous to the “Add to Playlist”)? This way, there would be a single and consistent way of assigning Lessons to either a Course or a Playlist. Just a suggestion… Take it with a grain of salt.