Lesson audio not downloading on IOS?

I cannot seem to get IOS app to download any lesson audio.

Tried refreshing lessons, clearing the audio cache and restarting app (v5.0.26(1)). Now playlists doesn’t work and sentence mode has changed to computer-generated speech.

Lesson audio seems to be accessible only from the website version of Lingq.

Is this a known issue?

I have the same problem :frowning:

I have tried again and now it seems to be working

Great, thanks for letting me know.

@Seby0815 Are you still experiencing the same issue?

yes, I still have this problem. And now it even doesnt create the audio automatically anymore for imported youtube videos like it used to do :frowning:

Do you have problem with YouTube imports only? What exactly happens when you import them? Do they remain without audio?

The IOS app is not downloading audio again. It seems to be temperamental. Occasionally it seems to work perfectly & downloads audio which it had previously refused to download. But most of the time over the past few days it simply does not work.


  • when I press the black download icon for a particular lesson from the course details page, the animated loading icon spins for a few seconds and then reverts back to a black download icon.
  • when I open that same lesson, the % sign next to the headphone icon remains stuck at zero & the audio won’t play
  • As per your query below, when I import content from youtube, the audio seems to be created OK but cannot be downloaded on the IOS app.

Can you guys please message us directly from the app, so that we can check your logs and try to figure out what’s going on? Thanks!
Please also mention your issue when you submit email from the app, so that your developers know what’s the problem you are experiencing.

Yes my primary issue is with imported YouTube videos. Before the problem occured, the original audio from the video was generated automatically after a while after the import. Now I only have the option to click on “generate audio” which creates a robot-voice-audio that is terrible.

1 Like

I have the same problem unfortunately.
EDIT: I have this problem on google chrome, when I import a lesson it appears to me to generate a robot voice instead of the original audio. Anyway, the whole idea of generating the audio of the lesson with a “robot voice” has problems, for example when I imported a 30min lesson from YT it was divided into 3, in the first lesson the robot generated the 12min audio well, but in the next instead of 12min, I had a minute, and at the 3rd 0 min … and instead I have to watch the video on YT that appears in the corner (that small window), which does not “record” well how many minutes actually I listened … so if it’s a new update … things got worse in my opinion.

@Seby0815 @iSilencio Are you guys also using iOS app?

1 Like

@zoran Oh sorry I dont use iOS I use the android version to read on my tablet. But I import the lessons on my laptop via the web version with the opera browser. I liked to download the audio as mp3 to use it offline on my phone when I’m outside (hiking etc.) because the app doest start sometimes while being offline (Another problem that would be nice if it would be fixed). Downloading the mp3 is more reliable but as I said it doesnt work anymore (only with the robot voice). I havent tried different browsers yet but I will later after work.

@zoran It seems to be working on chrome for me :DDD