Language Selection Issues

All of a sudden a language I deleted weeks ago (Japanese) is back in my list and Russian selection keeps switching over to it. Unable to keep it on Russian while I import a new lesson in the browser app.

Looking at the iPhone app, it is also confused, showing Japanese as a language choice.

Japanese keeps coming back after:

  1. Deleting the course again
  2. Clearing cache from the browser on the mac
  3. Deleting and reinstalling the app on the iPhone
    Workaround at the moment while importing a new lesson:
  4. Make sure that while importing the target lesson is switched back to Russian, because that’s the moment that Japanese appears as the target lesson
  5. Otherwise make sure that Japanese is never selected by the app and I explicitly choose Russian
1 Like

The software quality at LingQ seems to deteriorate at an alarming rate. Even basic functionality is breaking left and right. It’s truly a sorry state of affairs. I reported this earlier today via e-mail, but I doubt anyone actually reads those. Here is a screenshot of me trying to import Chinese:

1 Like

Software development and QA isn’t easy. Yes: issues come up from time to time. On the other hand I notice that the issue is already fixed. Lingq is very responsive.

Thank you Lingq support for fixing this issue.

Well: it’s some better. Still wants to revert to Japanese when adding a new lesson to a Russian course.

You’re right, I’m mildly frustrated, I shouldn’t have posted at all. And I normally confine my bug reports to emails, but it is just that the recent updates have rendered the web interface less and less usable. I certainly do not want to appear destructive or overly negative.

Regarding LingQ’s responsiveness: We obviously have different expectations / experiences, which is fine of course.
To me responsiveness in this context has at least two components: One, communication; that is responding to a bug report, by for example acknowledging the issue or asking for reproduction steps. And two: actually fixing bugs.

Here are the most recent examples of my interactions with LingQ support:
On November 4th I reported, only hours after the offending update, that clicking on specific courses can result in getting redirected to untoward websites. See a video demonstration here: - Google Drive

On November 13th I reported, again shortly after an update, that sentence mode got stuck on specific typographical devices commonly used to aid understanding or the division of text, these are also known as punctuation marks. Due to the severity of the bug I followed this up on November 21st by providing a video demonstration of the issue: screen.mp4 - Google Drive

Yesterday, November 28th, I had to find out that sentence mode had also been deprived of the handy feature that allows listening to the matching audio, provided the timestamps are accurate. So in effect, sentence mode, which had thus far been my favorite way of studying on LingQ, has become unusable on the web interface.
And if that wasn’t enough, as of today, even importing is borked.

There has been no response by LingQ in any form.

These issues are of course only the most recent, I haven’t even mentioned all the previous regression, like the broken text to speech in Chinese Traditional, the broken timestamp feature in the same language, the unwarranted inclusion of spaces in the printed pages across all three Chinese languages.
And then, there are all the things that have never worked like ePub ebook importing in Chinese or LingQ’s unfortunate word splitting algorithm and its inability to understand non-Western punctuation marks.

I just wanted to explain where my frustration comes from. I hope you’ll forgive me this rantingly long response. Let’s just hope LingQ gets a handle on these issues. In the meantime I will try to adopt a more positive attitude and try to enjoy the things that still work.

I should add that I did have fruitful email discussions with Zoran in the past, and I have no doubt that the LingQ developers are competent. I fondly remember the tremendous speedup provided by the backend developers and the special accessibility feature that allows rapid page turning on iOS. In fact, most of the issues I mention are relatively recent regressions and I agree, the issue probably lies with the Q&A process.

Switching Chinese to Japanese when importing lesson (manually) …

Yes, the same happened to me yesterday and this evening.

I’m using win11 web login on laptop, using both Chrome and also its same on Edge when at ‘edit course’ view and trying to ‘add lesson’.
Got round it by using Library page and ‘import’ logo, then it stayed on Chinese and did not switch to Japanese, so successful workaround.

Thanks, Frank

Great, thanks for letting us know it works fine now.

Hi Zoran / LingQ Team

This issue is still happening for me … now my Tagalog page is showing as Japanese icon (which I have never selected with LingQ)???

Please also see other comment of mine further below on this same thread. Using Win11 Web version Edge (and Chrome) browser.

Thanks for any feedback or advise, Frank

Thanks Frank, we will look into it again.

Here is a video showing the problem when importing:

This was recorded at 3pm CET on web version 5.0.139. Hope this helps.


The video zeros in on the same problem I have: adding a lesson to a course results in Japanese being selected as the target language.

Thanks! We aware about this issue and fixed it already, update will be available on production with new release (next week).


We pushed a fix for language switch, thanks for your patience.

1 Like

This case is fixed too - “clicking on specific courses can result in getting redirected to untoward websites. See a video demonstration here: - Google Drive” Thanks!

1 Like