Korean - When importing lessons, lingq adds incorrect spacing

When I’m creating a new lesson in Korean, lingq adds incorrect spacing in the middle of words.

For example:
놓친듯해 becomes 놓친 듯해
불안함을 becomes 불안 함 을

I’ve tried going back and deleting those extra spaces. When I hit “save,” all the text loads correctly… and then, two seconds later, the letters shift over and the spaces reappear as I’m watching it.

Resplitting doesn’t fix the issue, and I’ve tried copy/pasting the text as well as importing a .docx.

Sometimes it’s just a particle that gets shoved over, which isn’t a huge deal. But often, the bit that gets shoved over is an actual word when on its own, and that gets pretty annoying when translating and trying to study, as it can cause the entire sentence to make no sense. And it happens in pretty much every line of text. Unless I’m comparing word-by-word with the original text, I may miss a particular word. (It took me a long, very confusing session to finally figure out what was going on.)

I saw a comment about a similar issue in Japanese from 4+ years ago. Has there been any progress on fixing this? Has anyone found a workaround?


That’s true and is an issue with Asian languages. We rely on a third party word splitter and it is not perfect. However, you are able to highlight those together and save it as a “phrase” which allows you to save the grouping together which is all you want I think. Once you know that this happens, you can work around it. We should have this improved in the upcoming update to 5.0 version.