Issue with sentence mode translation

Hi, i’m having issues with translation in sentence mode for Japanese. Please help.

1 Like

You might have to provide more detail so someone can help. Is it not functioning? Or are you questioning the translation it provided?

2 Likes

Set your default translator as DEEPL rather than google translate. Try not to use sentence mode too much, it’s actually better to just go word by word only use sentence mode on particularly difficult sentences. Some translations via sentence mode can be inaccurate but using word by word you should be able to understand the meaning, don’t doubt yourself. If you’ve imported from YouTube then sentences may be wrong due to YouTubes auto translator itself not understanding the Japanese properly. My recommendation is to find lessons on LingQ itself and then import them as I find this has always been more accurate.

3 Likes

Yes it is not functioning at all. This has been happening for a week

2 Likes

We are looking into the issue. Thanks for your patience.

1 Like

Really? Why? Cites?

I say Sentence View is the core functionality of LingQ.

That “Show Translation” has been broken for a week now is shocking indictment of LingQ’s development process. “We are looking into the issue” is not at all a satisfying response, especially given LingQ’s feeble history of fixing bugs.

“Show Translation” is a key part of my learning process. And why not? Isn’t that an absolute requirement for a language app these days?

1 Like

Word by word does not work well in Japanese. One Kanji can represent several different meanings (and have different pronunciations). The choice depends entirely on context: the rest of the sentence.

For example, the 3d sentence in mini-story 20 uses the kanji 外. In the full sentence it is pronounced “soto” and means “outdoors”. But if you click on the word, the voice says “gai” and the text shows several pronuniations: gai, yoso, to, sodo, to no, hoka, soto. Possible meanings include “outdoors”, “other”, “external” and “except for”.

2 Likes

The whole point of LingQ is to learn via context, going word by word has helped me because I’m acquiring more faster. Maybe I’ll make some mistakes later down the line, but that’s how our brains learn and information gets processed. I’m not too fussed about getting 5% wrong if I’m getting 95% correct. Just the other day I managed to chat with a Japanese person online. They could understand me, and that’s really the ultimate goal. To understand and be understood, even if I made a few mistakes. They knew what I was trying to say. When those different pronunciations show up you can press on them to then change the transliteration and pronunciations of it.

2 Likes

Steve kaufman himself said another forum that the sentence translations, especially for people with it set to google translate and especially for Japanese, was bad, and he recommended setting it to DeepL as the main translator. It’ll be more comprehensible then. And the “Show translation” feature has been working completely fine for me. Learning with sentences later may be helpful but depending on where you are in your studies, I recommend you pick out words you know.

I (…) to the park (…) and walked, my pet (…)

I don’t need every word in the sentence to understand this, gradually I’ll be exposed to the words more and I’ll learn them in due time. You’ll be engaging your brain more if you have to put more effort into it.

1 Like

It does not matter much if the translation is not accurate. I can manage it by understanding the context. Also i have already set DeepL as my main translator. But what is the use if it is unable to translate. The sentence mode translation has not been working for more than a week and no one has come close to solving. Is this what we have to pay for even though there are other resources available that are much cheaper. please solve this as soon as possible.

2 Likes

The sentence translations are working for me. Are you on mobile or PC? I’ve found emailing LingQ support usually gets faster and better responses than on the forums.

2 Likes

I use only PC for lingQ. This problem also occurred in the past but it was resolved in few days. But this time it is taking much longer time. don’t know why?

1 Like

Agreed. I use it occasionally for French, mainly when a sentence completely throws me, in which case it usually throws the translator too. I use it a lot in German.

I sure use “Show Translation” for those “word soup” situations when I know the words, but they just don’t make sense put together.

I also like “Show Translation” as a pellet for me, the lab rat. I am pretty sure I know the translation, but it’s a quick dopamine hit for Google Translate (or whichever) to tell me I nailed it.

Yeah!

1 Like

We pushed a fix for this issue and it should be working properly now.

2 Likes

Thank you for trying.
French on a browser isn’t working at all - 0%. Greek worked fine. ("Android Boox, firefox).
I use this as shortcuts and macros don’t work on the app.
Please fix it. I’m tired of getting around LingQ shortcomings although I acknowledge it does some things very very well.

1 Like

@bbbblinq “Show Translation” is working now for French on Windows 10 Brave.

I did notice I had to restart the browser then go to the LingQ web page for the fix to take effect.

2 Likes

Seems better but not fully right. Thanks for the tip though. I am restarting the machine.

1 Like

Thank you for the support. It is working now.

3 Likes