Is any Chinese learner missing PinYin?

The behavior I see:
on web:

  • Transliteration → Off → Pinyin still shown in sidebar / pop-up, no Pinyin above text
  • Transliteration → Pinyin → Some words (no color, blue, yellow) have Pinyin above them
    on iOS:
  • Transliteration → Off → no transliteration at all not in the pop-up, not above the words
  • Transliteration → Pinyin → Pinyin above yellow and blue words also in pop-up
    Personally I don’t use transliterations, including Pinyin, and would prefer not to see them at all, so I actually like the way it is on iOS now. But I agree there was definitely a change in behavior with update 5.3.3 on iOS. I don’t use the website regularly so I can’t comment if anything changed there.

As mentioned in my email reply, Pinyin is controlled in the settings. If it gets turned off in the popup because you tap on it, you can bring it back by toggling the setting off and on again.

There seems to be no way to have pinyin only in the popup as of the newest update. Previously, pinyin or traditional characters (but sadly never both) were part of the popup even when they weren’t displayed above the text.

This should be reverted ASAP, as it has deleted the best use case!

The Chinese Word Separator chrome extension is helpful if you don’t want to alter LingQ settings to display/deactivate pinyin.

3 days ago when I had pinyin toggled on, as I currently do Pinyin was displayed over every character whether it was a known word, a blue word or a lingqed word. Now regardless of whether I toggle pinyin off and on in the settings the only displayed pinyin is over lingqed words not known words or even lingqed phrases. I believe I’m toggling the correct settings as you can see in the attached screen capture. Is this how the Pinyin is currently being displayed in LingQ, exclusively over yellow lingqed words? if so that completely changes how I study Chinese in LingQ.

1 Like

I think there are four configurations a user might want:
(T = Transliteration)

  1. T above the text for all words and T in pop-up / widget
  2. Only blue / yellow words get T above the text and T in pop-up / widget
  3. No T above the text but T in pop-up / widget
  4. No T at all
    Currently, only use cases 2 and 4 are served, by setting it to “Pinyin” or “Off”. To my benefit, 4 was newly introduced. 1 and 3 seem to have been removed.

I tried a few other languages:
Chinese Simplified / Traditional / Cantonese:

  • Pinyin: T only above blue / yellow words and for all words in popup
  • Romaji: T above all words and for all words in popup
  • Hiragana: T only above blue / yellow words and for all in popup
  • T only above blue / yellow words, T for all words in the popup

Japanese Romaji appears to be an outlier.


Thank you this is exactly the confirmation I needed . As you stated pinyin is only appearing over blue and yellow words for simplified Chinese. Where as 3 days ago it was appearing over all text. Exactly like Japanese Romaji. Something has changed and it would be nice if LingQ support staff acknowledged this change. Again thank you for your help it’s much appreciated.


I’ll ask our team to look into this. Thanks for all the details.


Hi everyone, just an update here.
Transliteration is now only shown for blue words and saved words with status 1/2/3/. It is not being displayed for known or ignored words.

Thank you for the confirmation.

I repeat myself, but for the sake of concise feedback: I urge your developers to return transliteration to the popup. Either as a default (as it was before), or as an available option.

This was my preferred use case, and I can’t imagine I was alone. I’m currently forced to emulate it by cluttering my saved translations with pinyin instead.

1 Like

Thank you for the update. Transliteration on every word in sentence and page view was extremely useful for beginners in non-romanized alphabet languages. I think by removing the option it raises the threshold that will prevent new learners from utilizing LingQ. While I’ll adjust my learning on LingQ habits around this change I do hope your team will reconsider the removal.


Well, I dislike this update.
I want to have pinyin over all characters, this way it forces me to think in term of sound, which is what I’m struggling with. It’s easy to recognize the characters, but it doesn’t mean I remember which syllable is it, let alone it’s tone. I want to be constantly reminded about it in a passive way, while I’m reading.
Also Lingq tends to split words wrongly. I disable the all blue highlighting and only look for words, I’m curious about. So I don’t want to have selective pinyin, because it gives a hint how Lingq (probably wrongly) splits words and distracts me from figuring it myself.
This behavior should be configured in settings.


Agreed it’s a terrible “fix” of something that wasn’t broken at all.


Yes, no pinyin on my known words either. Please fix this!!!

1 Like

They have no plans of restoring that feature. Which is a shame and counterproductive for an app that sells itself on comprehensive reading.

Originally I thought the idea of introducing transcriptions for a number of languages, like Russian, Arabic, Korean, etc. was to make things easier for beginners. But it’s unfortunate that the same update introduced a regression for Chinese that contradicts this noble idea.
I even sent a message to the developer in charge, but no cigar. So this feature might be gone for good. It seems the best / only way is now to save the Pinyin along with the meaning.

1 Like

thank you for explaining that it was the introduction of transcription that spurred the change. unfortunate but understandable, hopefully they find a solution in the future.

FWIW, Pinyin is back on the popup, so it’s no longer necessary to save it with the translation (except of course where there are several pronunciations and you disagree with LingQ‘s suggestion). But yes, transcriptions (or, actually, traditional characters) above the text seem permanently disabled for ”known” words.

I think I get the idea: if the transcription is a learning aid, it makes sense to turn it off once the word is learned. But there are so many preferred use cases on LingQ that I do wish it could be customizable… (I personally don’t want pinyin above the main text, as I find it distracts me from focusing on the Chinese characters. But I do like to display traditional characters as a way to familiarize myself with them, and I do wish I could have them displayed on known words, too!)

1 Like

Exciting addition of a toggle switch for pinyin only for hanzi between level 1-3 or for all words on the web app. Thank you to the whole team! Hopefully we’ll see it in the mobile app soon :grinning:

1 Like

It is not possible to have transcription only in pop-up, like before ? I don’t understand why it has been removed, Pinyin is a complement of a character