iPhone app - some lessons with incomplete audio


I’m having a slight problem with some lessons. When I first loaded them, they had the full audio, but now some only play, for example, 20 seconds of a 2 minute lesson. I’ve tried restarting the app but still have the same problem.

Is there some way to reset lessons in the app?

Sorry if this has been asked before…

@wato - I’m not sure why this happened but what you might want to try is clearing the MP3 cache in the Settings on the app. Let us know if that works!

Thanks, I knew there had to be a simple fix!

Hello again,

I’m having the same problem with the app, only this time deleting the cache doesn’t work. So I’m stuck with some 4 minute lessons that only play for 16 or 20 seconds. I was powering through some listening last night and the app was very slow to load the lessons, not sure why. In any event I’ve tried closing the app, playing the lesson again through the website, switching to off line and back to on line, rebooting the iPad, deleting the cache and these bad boys still refuse to load the whole lesson :slight_smile:


@wato - If it’s just an issue with this specific lesson then it may be a problem with the audio file itself. Have you had the same issue with other lessons? Also, would you be able to link me to this specific lesson?

The first lesson I have the problem with is chapter 20 in the Linguist book in Russian. It only has 23 seconds (interestingly, not the 23 seconds at the start):

The next chaper, 21, only has 16 seconds:

I have listened to them both on the app with no problems before (which I thought saved them on the app for off line listening?), but last night they were really slow loading and didn’t load fully. There are a couple of others too.


@wato - OK, thanks for links to the lessons. These lessons seem to be OK, so it may be an issue in the app. We’ll look into this and get back to you shortly!

@wato - What happens when you open the lesson and play the audio file? Does it start loading the rest of the audio file, or does it only play 23 seconds or 16 seconds then stop?

I spoke with one of our developers about this and he is wondering if you tried anything similar to the steps below:

  1. Disable background audio and clear cache in settings
  2. Start playing lesson while still downloading
  3. Hit home button to quit app
  4. Start audio again using remote control functions (double tap home, swipe left, hit play)

Lastly, he recommended trying to delete and reinstall the app to see if that helps with these audio files.

I tried the first step and they work now. I’ll remember that for next time :wink:

What happened was I selected the lesson and it would just show the audio track as 16 seconds etc. It wouldn’t actually load anything, or I should say the bar didn’t appear. It wasn’t the start of the lesson but a random slice somewhere in the middle.