iPad and iPhone apps not updating words from New to Lings


When I change a New word to a Lingq using the iPad or iPhone app it goes yellow but the number of new words (on the left side of the iPad screen) doesn’t go down, nor does it add to the number of words in the flashcard part, I tried logging out and back in, the words all reverted to blue.

It was working fine yesterday and I have the latest updates installed.

Hi! I checked this on my iPad and it seems to be working relatively well with the latest version. The New Words number is updated locally and is only synced with the server the next time the lesson list is loaded. This means that the New Words number may not be exactly accurate while you’re actively working through the lesson.

Sorry, posted too early! I was going to say that it sounds like this issue may have been caused by a weak network connection. Perhaps you can try closing the app and opening it again, or even uninstalling it and reinstalling it to see if that helps.

Interesting -hmmm… before, say I had a new lesson and it had 30 new words, every time I changed one to a LingQ the number on the left side of the lesson page decreased. Now if I select a new word, it brings up the hint but the example phrase is blank. If I assign that hint to the word then when I use the flash cards after a lesson there is no example phrase. If I use the website instead of the app I can lingq as normal. Strangely enough, when I use the app to look at my daily Lings their status changes as I go through the deck and it is reflected on the website. The problem is only when I look at a new lesson. I tried deleting and reinstalling the app but still the same problem.

Ok - really hate the ‘return sends the post’ idea!! How do I get around that on an iPad? My connection is a bit sketchy at times but I can use the website no problems, and until a day ago I used the app without any problems. Also if I use the Android app on the same connection it works ok at creating Lings, the new words go down as I create them, but the example phrase becomes a series of characters and numbers - Тк&#1072 is the default example phrase for all the Lings I create on my android phone. If I look at the same article on my iPhone, iPad or Android, the phrase is the character and number combination as above. If I look at that article on the website, the example phrase for the same LingQ (and all other Lings I’ve created on my android phone) is “Тка…” It’s all very strange.

Right something is strange - the first Тка in my reply above was actually a string of numbers and characters when I typed but when I hit return it converted to Тка. Also when I went to edit that reply it showed them again as numbers… hmmm

The issue with the Android app you report is a known issue, and we’re hoping to have this fixed in a new version that should be ready some time next week.

For the iPad, I’m actually not too sure what would have changed here. Did you update your OS recently on the iPad? We’ll do some testing here and see if we can reproduce the blank phrase issue on the iPad.

The phrase issue should hopefully now be fixed - would you check this again and let us know if you’re experiencing the same issue?