iOS app crashing and won't restart

I had this issue earlier today: marked a word as known and the app crashed. Then it would not start up. Had to uninstall and reinstall the app to get it working again.

Now it is doing it again! The app will not restart. The splash screen appears and the app crashes immediately.

Rebooting the phone does not fix it. I’m on the latest OS and the latest Lingq version.

1 Like

I haven’t updated to the version 5.5.5 yet. Maybe I wait a little bit.
What iPhone version do you have?

1 Like

What app version are you on?

1 Like

I recently reported the same issue with my iPad, latest iOS. It happens daily, sometimes many times over an hour. It’s with YouTube imports.

When it first started, I was on the most previous version. In an effort to solve the issue I updated to v5.5.5 (0). Apple OS is the latest 17.3.1.

After being gone all day, I tried to make it happen and so far it’s behaving itself.

1 Like

I was in fact reading audio that originated with YouTube and was transcribed by Lingq. I was reading the transcription.

Might be of interest to @zoran

2 Likes

I have new information about the crashing – and it just happened again. First time since yesterday morning. I will email the exact lesson ID I was working with, though that does not seem to matter.

Specific details today: 5.5.5 (0). I edited a sentence in the iOS app. Actually edited the sentence twice to correct two words that were transcribed incorrectly. Then I marked one as known and crash. Once again the app will not start up.

I just now updated to 5.5.6 (1), but the app won’t start up. I removed the app and reinstalled. I edited the sentence again (just once), only this time after editing I marked the new word as “ignore,” and the app crashes. So now I can duplicate the issue at will.

4 Likes

Here are lots of details most of which you’ll find in my email to link support:

I was reading this lesson using v5.5.5 (0) in iOS 17.3.1.
I used the "Edit Sentence" feature to edit sentence 9 of the lesson: " Пользоваться – это овр глагол из группы ова глаголов,"
I marked the corrected word as known and the app crashed
The app would not start up again as reported yesterday
I deleted the app and its data
I went to the app store, found that there was a new version of the app: 5.5.6 (1) and installed it
The app starts up again
I went to the same lesson and the same sentence and made an edit
This time I marked the newly edited word "ignore"
The app once again crashes and and won't start up
I delete and reinstall the app
This time I make an edit and linq the edited word first and life goes on just fine - no crash
I edit the sentence again and mark the word as ignore, and it crashes
3 Likes

Thanks for the info, we will look into it.

2 Likes

Hi there, I have the exact same problem with my iPad. Super annoyingly really ! Hope it gets fixed soon.

1 Like

We pushed an update with a fix.

3 Likes

That’s excellent! Thanks.

Works now, thanks a lot for the swift intervention!

1 Like