Incorrect New Word Count in Persian (Continuing Problem)

Hello. I am trying to import a text file but no matter what format I save it in, LingQ says 67% of the words are unknown. This is much too high. The vast majority of the works in this file I already marked as “known” in LingQ.

I have raised this issue before with Persian, and Zoran said it was due to character encoding. So I tried to save the file in various formats and encodings (UTF 8, UTF 16, as PDF, as HTML, as Plain Text) but none of them solve the problem.

The lesson I am having a problem with is here:

Another lesson that has the same problem is here (I did not import this one):

1 Like

Thanks, I will ask our team to look into it again.

thank you Zoran. I would think this would be a fairly simple problem to solve. Between this one and the “zero width non joiner” problem that another user has identified, it makes using Persian on LingQ much more difficult than it should be.

I fixed one of the problems. The issue with the file that I imported was that there was an extra character (“_”) in most of the words. So است became اسـت. I did a find-and-replace for that extra character and it solved the issue.

However, I still do not understand why this one is saying all words are unknown: