Importing texts

Hi there. I can’t import plain texts the traditional way in English and Italian, I don’t know if they have something to do with the updates, but I don’t think so. Trying to import texts in English I get this error:

Video form errors:
Field “youtube_url”: Escribe un enlace válido.
Field “language”: Este campo es obligatorio.

If I try to import in Italian I get a 500-Server error.

In French it works fine.
I haven’t tried the bookmarklet yet, if I notice anything I will tell you too.


Così impari a non voler usare le nostre lezioni! :stuck_out_tongue:

For the first error, scroll down and select Video from the “Select Resource” dropdown. Then delete the text there and it should work fine.

We’ll have to take a closer look at why you might be receiving a 500 error for Italian. For starters, be sure to clear your browser’s cache, as that might help.

The first one is fixed, thanks.
About the 500 for Italian, I cleared up the cache and even tried on different computers and different texts, no luck so far.

@michele: :smiley: Voglio tutto!

It seems to be working fine now, no idea of what it was…

Glad to hear it’s working now. Let us know if you notice anything else strange happening!

I am having similar problems. The following appears sometimes (not every time) when I try to save and open an imported lessons.

Video form errors:

Field "youtube_url": This field is required.
Field "language": This field is required.

I’ve had this problem and it comes from doing something like pressing back to go to the import lesson page. Load the page once and it doesn’t have the problem. At least, that’s my experience.

Hi Alex,

I was having a similar problem importing in German. I did what you suggested. As a result, the red message disappeared, but the lesson will not open. Unfortunately the bookmarklet will not resolve the problem as I am trying to import from a news site where images are embedded in the text. Highlighting goes over the pictures, in which case the text will not go into a lesson. The alternative is the import the text through the bookmarklet in little pieces. This means re-loading the page for each section.

I hope you can help.

If this happens, just click on the “Select Resource” dropdown and select Video. Then delete the text that is there and you should be good to go.

This happens when you navigateto another page then use the back button.

Can you give me a link to the lesson that you can’t open? The link from the Import section will be fine. Also, can you provide a bit more detail about which website you are trying to import lessons from?

Thanks Alex.

I am importing from Deutsche Welle.

This is the link:

The space before the 46 does not appear in the address. I do not know how it got in here.

Here it is again:

Again with the space! I simply copied and pasted.

Longer links get truncated on the forum. It’s fine though – I just removed the space.

I don’t seem to be having any problems opening this lesson, though.