Importing failed - decode() argument 1 must be string, not None

I got this error when trying to upload an ebook to lingq i have no idea what it means and how to fix it. Is it possible to fix please let me know and thanks again!

Please send me that ebook to support(at)lingq.com and I’ll take a look. Thanks.

Ok will do, Also would there be a problem if the book was say 2000 pages or something absurd like that? its basically a complete series of books.

That is a lot, but it should still be imported. Longer books are split into parts on each 2000 words.
Based on error message you see, sounds like the issue is related to book format.

I have gotten around this problem in the past by converting the book (in an epub format) to a txt file using calibre. https://calibre-ebook.com/ If you’re still stuck, I would highly suggest giving that a try. :slight_smile:

1 Like

i converted into epub and pdf but it is written in gibberish because the books are in korean and i guess pdf/ehub doesnt like that? when i try to put into a word document it just looks like code. It wont let me upload directly into link because of DRM i think but normally i put into word and copy and past but because word isn’t displaying hangul for some reason. i can do it.

‘NoneType’ object has no attribute ‘content’
i just got this error type on an ebook as well. it says its an epub.

Yeah, same with me, I have only ever imported books in Korean. I really suggest trying to convert it to a txt file because then the only thing in the file is the raw text, which is then easier for a computer to parse/read. Let me know if you need help with converting the book. :slight_smile:

1 Like

I will try text file just saw calibre does text lol it should work and is there a place to search for books that arent originally in Korean other than harry potter? My Korean is to weak right now to read native material where i don’t know what happens lol. Also does txt file conversion work on books with drm from kindle/google play store etc?

1 Like

I think you can remove the drm using calibre, but I don’t use kindle so I haven’t tried it. As for where to find books, great question lol. I’ve had issues trying to get ebooks and audiobooks from Korean sites (kyobo, naver audioclip, etc.) before because they usually require a Korean credit card or bank account, which I don’t have. I’ve really only had success with pottermore and apple books, which is also pretty hard to sort by language. :frowning: If you have netflix, I would recommend importing Korean subtitles from shows you have already watched in another language and reading them in lingq. You could also do this with youtube or reviews/wikipedia pages for books or movies where you already know the plot. I’m also struggling with finding things to read right now so I feel you.

1 Like

as far as reading shows on netflix if they don’t put who’s talking in () next to whos saying what its kind of hard to follow since korean doesn’t say subjects and don’t conjugate by person. also that file im having trouble with is from pottermore even in a txt file it’s gibberish and has DRM apparently i imported one of the tiny books and it worked but the main books arent working ive tried all the formats but it just says it’s protected which is odd because pottermore books are supposed to not have drm?

Are pottermore books DRM free?

what does this error code mean
‘NoneType’ object has no attribute ‘content’
also now its saying its DRM protected even though the site isn’t supported.

Hmm, I’ve got several of the main books from pottermore uploaded to lingq as txts. I’m sorry it’s not working :frowning:

1 Like

Unless they have changed it within the last few months, they should be!

1 Like

did you buy the books as a whole collection or just individual books?
I’m just gonna get a refund and rebuy them they didn’t come in epub like they said they came in rtf file whatever that means.

I got them individually and they came as epub files.

1 Like

Wait, actually if they came as rtf (rich text file) you should be able to convert it to plain text (txt) using a text editor.

1 Like

“I got them individually and they came as epub files.” that makes sense I bought whole collection but getting refund gonna try with individuals and see if that works. also what text editor would you suggest and how is that done?

I use TextEdit but there are plenty of applications that do the same thing. I’m sure you already have one on your computer. Just open the file in the text editor and there should be an option to convert to plain text. Alternatively you can just try changing the file extension from .rtf to .txt