Import Vocabulary

Until recently, I was using a competing system to LingQ, which allows me to export vocabulary. Now that I have switched to a paid membership of LingQ, I wish to import this vocabulary into LingQ,.

Alas, I am confused about the format required by LingQ’s “Import Vocabulary” feature.

As far as I can tell, LingQ requires the format to be comma-separated, with each “row” being “word, hint, phrase”. Is this correct?

If so, it causes me quite a problem since many of my vocabulary entries contain commas (for example, quite a lot of “hints” have multiple comma separated words in them. For alternation definitions of a word. Likewise, a very high percentage of phrases do.

In addition, LingQ itself supports LingQ for groups of words (by highlighting several words and then providing a LingQ for them)/ These groups themselves may contain a comma, which makes me confused about they can imported too.

At the very least, is it possible to support “tab separated” format, rather than comma separated?

If not, I am pretty much screwed, and will probably have wasted the one year membership I recently paid for, since having to recreate manual LingQs for thousands of words will take me months of effort (rather than the thirty minutes of importing I had expected).

Thanks a lot,

@AnthonyLauder - The other system should export these words with the hint and phrase in quotation marks. As long as a hint is in quotation marks, commas are OK. If they don’t allow you to add quotation marks around the phrase or hint then there may be some other options. If you can’t figure out the quotations then email us (support (at) the list of words you’re trying to import and we’ll see if we can help.

Thanks a lot Alex,

I will now work on adding quotations marks to the exported file before importing.

This leaves me with just two questions:

(1) When I import vocabulary, which level of “knowness” is it set to (0,1,2,3 or 4) and is there any way to specify this for each word being imported?

(2) What happens to those words in the file which already have definitions in LingQ? Do the imported ones replace the existing ones, or are they ignored, or even somehow merged with the existing definitions?

Thanks again

@AnthonyLauder - At the moment all imported words are given a status of 1, so you will need to adjust the status manually. If a word already exists in your database, the existing word will stay the same and the imported one will be ignored. Let me know if you have any further questions about this!


Great. I have now created a CSV file in the correct format, and have imported it into LingQ.

More specifically, I submitted the file via the “Import Vocabulary” dialog box, and now LingQ has for the last forty minutes been showing a spinning disk and states “Importing …”.

Hopefully, this just means the import process is rather slow, which is not surprising since my CSV file contains 22,000 rows.

I guess I now have to just wait for it to finish, and I will report back tomorrow on whether or not this worked (since it is bedtime for me here now).

If it does work, then you will have saved me months of manual addition of words, and I will be deeply grateful to you.


@AnthonyLauder - Sure thing, let me know how it goes. If you find the 22,000 row CSV file taking too long, you might want to try a 10 line sample file just to make sure it works!

Anthony, what you describe is what happened to me (and eventually what made me stop using the system). I tried several computers, different operative systems, and browsers. I followed detailed step-by-step instructions (which matched what I had already been doing), but to no avail.

I sincerely hope the system works for you.

Importing a CSV file has worked for me in the past.
However, sometimes the import completes without notifying you. And the process can take much longer than you expect (or hope).
After an import attempt, go directly into your Vocabulary and search for some of the words you imported.
Finally, if the import process does not seem work, definitely try Alex’s suggestion about importing a 10-line (or even 2-line) sample file.
And if that doesn’t work, well, you really do have a problem :-(.


I seem to have worked out the problem. The first issue is that the copy-and-paste import vocabulary options (directly into the dialog box) do not seem to work at all. They only seem to accept terms (words) and no hints or phrases for them. This seems a severe limitation, but is not a problem for me (other than explaining why some of my tests failed).

Now onto the import from files. I am now able to get it working most of the time if I have no more than about 20 rows in a CSV file. However, the result can be one of four:

1: All rows correctly imported and LingQ informs me that it succeeded
2: All rows correctly imported but LingQ spins for ever telling me it is importing (I have to stop it after a minute and check whether or not it finished)
3: No rows imported and LingQ spins forever telling me it is importing (I stop it after a minute, and see that no rows have been added then reduce the file size and retry)
4: All rows imported but some are corrupted on import (I then delete those corrupted terms from the vocab in LingQ)

It is rather messy and time consuming, but I can at least now make some progress. Given that I have 22,000 terms to import it is going to take several days of effort - which is far from ideal. However, it is still much faster than adding one word at a time manually. So, I can live with it.


Unfortunately, the import did not work at all. I left it running for more than 11 hours, then checked in a separate browser tab, and no vocabulary had been added at all. So, I tried a smaller file - with just three rows in it - and it did import them, but they were corrupted. So, I tried with just one row. Specifically:

“Blaníkem”,“a place name”,“pod Blaníkem”

This, unfortunately, was imported as a single term (i.e. the complete text appeared as if it were one long word) with hints and phrases left blank.

I then tried the other two “import vocabulary” options (import a single term, and import by pasting a list of terms) using the same text above, with the same result.

I cannot think of a more trivial example than this one, yet I cannot get even this working.

Has anybody has any success at all with importing? What can I possibly be doing wrong in the trivial copy-and-past of the above single row of text?

Certainly, I must be doing something wrong, but cannot figure it out.

A very frustrated Anthony


Success! It was quicker than I expected!

I managed to import 22,000 terms - in small chunks - in just a little over four hours of non-stop manual work. Although this took a bit of effort, I am happy that it worked.

There is now one final step I cannot work out:

All my imported terms have a status of 1 (as mentioned by you above). Now, this is fine, except that many thousands of terms are actually “well known” to me. To make it easier to identify these terms, I have imported these terms into LingQ with the “hints” field left blank.

What I need to do now is select all terms for which the “hints” field is empty and change their status to 4 (i.e. well-known). So far, though, I haven’t worked out how to do it.

Can you help me figure out how to select these terms and change their status please?

Thank in advance

@AnthonyLauder - Wow, glad to hear that it worked out in the end!

At the moment there isn’t a way to sort words based on the hint. Did you import the well known words in a batch or are they mixed in among your other LingQs? If you imported them all together, you could use the Creation Date sort filter then find the page where they start and select up to 200 at a time. If not, you may need to slowly work your way through these words either in the Vocabulary section or as you’re reading through texts.

That’s a shame. I shall just have to do them by hand then. The main thing, though, is that I now have all by vocab imported. So can keep using LingQ quite merrily.