Import vocabulary - csv import not working

I can not get a csv list to import. I’m using the suggested format:
seven,eight nine,


I’ve tried preparing & exporting the list in 4 ways: Excel, Google, plain text file as .csv, and Numbers for Mac.
All 4 methods import in to any other program successfully, but not lingo. It just remains on “uploading” without completing.

I’ve also tried doing the importing from 3 different browsers Chrome, Firefox & Safari

When you export from Lingq, it is written in the format:
word,“[[”“en”“, ““hint””]]”,phrase ( I assume ‘en’ is a tag for ‘English’)

so sure enough, if I modify the list I’m trying to IMPORT to:

one,“[[”“en”“, ““two””]]”,three

Then it imports fine.

Obviously, adding all the padding “[[”“en”“, “””“]]” is impractical, so it doesn’t really solve the problem.

Has anyone successfully got it to work using the proper straightforward format?



Thanks for the detailed feedback on this. I’ve passed this along to one of our developers and we’ll see what we can do to improve the import from .csv function to support more formats!

“I’ve passed this along to one of our developers…”

Importing Vocab into LingQ…

… did not work in January 2013: Import Vocabulary - Language Forum @ LingQ

… did not work in March 2010:

Who should it work in 2014, 2015, 2016?

We now have here silly avatars, colorful apples (at least my apple here in the forum has finally turned to wormy :-), and other questionable design gimmicks, but the import is just as buggy as 2008 or 2009.


If you’ve noticed additional issues with the .csv import feature be sure to let us know, as this will help us identify them and resolve them!

By the way, the apples are apparently quite popular if one is to judge from recent forum posts about them :slight_smile:

“… this will help us identify them and resolve them”. These problems are on your list for years. It would be better that you admit that LingQ has not much interest to fix or improve the vocab import. Your competitors have working import functionalities. Maybe you should have a look and learn from them.

I work around it by pasting my vocab words (script only), separated by commas, into my own lessons. Better than nothing. Besides, I much prefer vocab lists tailor-made and relevant to whatever course/book etc I happen to be using.

Edit: when I make lingQs from those vocab words, I keep Google Translate open on a separate tab. If there’s no info or no Romanization showing on the dictionary hints, I copy the character/s into Google Translate so I can copy the romanized script back into my LingQ hints.

If I’m not happy with either the LingQ or Google definitions, I’ll look up the word in my own hard copy dictionary for clarity, and add it.

Hi Alex, Thanks for the reply. It does appear from previous threads that this problem is being neglected, and while I appreciate there must be many things on the dev’s ToDo list… I think it’s CSV’s turn to get fixed!

I have some word lists organized by topic produced in other software, which of course can not be easily integrated in to LingQ.

Absolutely, and I’ll be the first to admit that vocab import (not just .csv) hasn’t been high on our priority list as it still isn’t a widely used feature. However, with the recent uptick in interest on the forum I’ve been doing what I can to try and move this up the priority list. Any additional information on specific issues is helpful because it gives our development team more to work with, and they’re more likely to work on it if there’s a solid starting point rather than starting with a generic to-do that says “.csv import isn’t working”.

So if you do have anything additional to contribute with regard to the .csv import issues, please let us know. Thanks!

Thanks, Steve. If you don’t mind, would you email me a couple of the .csv files that you’re trying to import that aren’t working? I can then pass these on to our development team to hopefully get them moving on this sooner :slight_smile:

Would you give the .csv import another try? We’ve made some updates that should hopefully improve the compatibility and improve error reporting. Let me know how it goes!

Hi Alex, hi Steve, does it work now ? I try to do a csv file, I think I succeed in. First column : - word in spanish ( language I am learning) and second column : word in French ( my mother tongue), but once the file imported, I only see the word in Spanish without the translation in my mother tongue. Is that normal ?

Thanks Alex and Ceceile, I’ll be back from holiday on friday and give it another try :slight_smile:

Hi Cecile! Would you be able to send the .csv file over to support (at) so we can give this a try?

Hi Alex, thanks very much, it seems to be working now :slight_smile: