Import problems

I can’t import any Ebook. It really doesn’t work well. It imports only one lesson and it does so in one block of text without linebreaks, the rest of the book doesn’t import. What’s the matter?

1 Like

I have a similar problem with the import of Chinese text.It shows itself like one block,almost all the words are stuck together and it’s impossible to discern them by clicking,so all the Lingq’s features are unusable,

I have the same issue. I thought I was doing something wrong. I have tried multiple formats (pdfs, epubs and docs). Unless I break any text manually into 2000 words or less parts and add them one by one. But even then, new words are not highlighted in blue.

I have the same problem when trying to import texts with the import extension!

Sorry about that everyone! I reported the issue to our development team and hopefully they will be able to find a solution and fix the problem soon.
Thanks for your patience!


Ajd,samo požuri bre :slight_smile:

1 Like

I really hope this problem will get solved soon as I am a new member who is just trying Lingq out to see whether this is something that I really want to spend money on. If I wont be able to import full books I most likely will not continue this as that feature is exactly why I decided to join lingq. I am a student and short on money so I have to say I am quite dissappointed right now. Hope you will be able to fix this problem really soon though, as I would really like to come to love this website/app.

Hey, they always fix their problems. Lingq is a valuable resource. I’m sure you’ll enjoy it. hasta!

the same here.quite unusefull this option if you don t fix it…and I’m paying a premium subscription…pls fix asap

Hi again everyone,
Some of you already did, but if you can send me a link to your imported lesson to support(at) and mention what specifically is broken in that lesson after importing that would be great. That will help our developers figure out the issue and fix it sooner. Thanks in advance!

I 've had two issues till now:

  1. if you choose to import a lesson using the dedicated channel, the system after uploading the lesson shows the error" lesson should contain less than 150000 words". Doesn’t make any difference if the lesson uploaded contains less than 150000 words: the system keep showing the same warning message.
  2. when you choose to import an ebook , clicking on the import ebook button, the system split the book in several parts but each of these parts shows and share the same content.
    Thank you

The issue should be fixed now, Please try again. Thanks!

I am still unable to import ebook. It imports only 1 lesson and nothing else. I used pdf format. Anyone had better luck after latest changes?

I uploaded an ebook in Russian, and though it came through a little funky (weird line breaks, spaces between words and hyphens in some places), it’s working fine. I love this concept!

I am still having this issue as well, where only the first 2000 words will be imported. It doesn’t matter if I try to copy and paste the entire text or use the import ebook option. Have tried both chrome and firefox but no luck. Are other people still having this issue? Would be great if it was resolved soon, since having to go through and copy and paste 100 imports to read a book would be a massive headache.

I’m having trouble importing a book. It’s Los Ingravados. I will send it to lingq support email as above

1 Like