Import errors

I am currently on a free account, but was thinking it’s time to got premium; however, I wanted to test the import functions first because it’s very important to me to be able to use the material I already have on my computer. However, neither the “Import Lesson” nor the “import ebook” options are working!

When I click “Import Lesson” literally nothing happens, unless I right click and open in a new tab, in which case I get at “500 internal server error.”

When I try to import an ebook, despite having tried multiple files, all of which should be DRM free, I get an error message that says to be sure digital protections have been removed. I found another thread on this from a week or so ago, but that thread indicates that the problem is fixed. At least for me, it doesn’t seem to be working.

Thanks in advance for any help!

@braininavat - That seems very strange. Just clicking on the white “+” button should open the import page. Which browser are you using? The ebook importer can have issues with different formats sometimes. Please send your ebook file to support so we can troubleshoot and resolve that issue.

Thanks for the response. When I click the white “+” button, I get a drop down list with “import lesson”, “import vocabulary,” and “import ebook.” When I click the first or third option, things happen as described in the original post.

I’m using Firefox. I can download another browser and give it a shot.

Sorry if I’m being dense here, but how should I send my file(s) to support? I’ve tried multiple files, all in docx and pdf format.

I just downloaded chrome. With Chrome, no change on the ebook issue, but there is a change with the import button. When I click the “+” it says import limit exceeded. If that’s so, and I just need a subscription, that’s fine. But, I don’t think I have imported anything, and I thought the free account allowed something like 5 imports. If just getting a subscription will fix it, then I’m not too worried. That still leaves the ebook issue though.

You should get the import page if you click on the plus button. If you hover on the plus button, you should see the dropdown you mention with those 3 options. Clicking on the first option opens the import page. I just tried it in FF and all seems to be working well. I’m not sure what to tell you. Do you have the latest version of FF? Which operating system are you on?

You can email your files to support at lingq dot com.

You are allowed 5 imports with a free account. But, I suspect that your efforts importing ebooks may be to blame for using up those slots. I will have our tech team look into that. That could also be why your importing is not working since most ebooks are over 5 lessons long. If you go to My Lessons do you see any imported lessons there?

It sounds like we need to add some messaging there if that is the case. Sorry about that!

That makes total sense! In that case, I think I’ll just upgrade and see what happens. Honestly, it will be a little while before I’ll need the import feature (because you have a nice library here!), but I didn’t want to start paying if the feature wasn’t going to work for me. The response here has convinced me that y’all will be helpful if I experience more problems, so happy to take it on good faith that if the time comes when I need it and it isn’t working, I can get help!

And, my lessons doesn’t have any imported lessons in it. Also, maybe relevant, when I go to the upgrade page it says I have 0 imports.

I can now confirm that upgrading fixed both issues, so I think your hunch was correct!