I can't import any lessons

I can’t paste any text to the empty field. The systems says that I need to save first, but I can’t save any content either. I hope that someone can help me, because I really like to import some Spanish articles.

Thanks in advance,


I also have this unplerasant problem - I wanted to import my two new lessons last night and I couldn’t do it for 25 minutes. When I tried to save the lessons, the system showed ‘Error’.
I am a quite persistent person and at last I managed it, but it was very long and with a lot of efforts!..
Tommorow I would like to add some more new lessons and I would like to have this bug be corrected.

Hello whelder2,

Are still not able to import lessons? I have just tried now and everything seems to be working fine.

At the moment I am able to import lessons. I switched browsers. Now that I am using Google Chrome everything works fine. It seems that the problem has to do with the Microsoft Edge browser. Thank you anyway.

Glad to hear it works fine with Chrome! Let us know if there is anything else we can assist you with.

I use Chrome as well, but it doesn’t work all the time.
For example, when I want to import a article from www.rt.com , it never works. Other websites are, for the moment, OK. :confused: