I can't download The Wildbeat

Tonight I was trying to find new audio materials to listened to.I was interested in the content ‘The Wildbeat’ .So I tried to download and listened to it.But I couldn’t. I can download other contents. So what is wrong with that?

Sorry.The content’s name is The Wildebeat .

Sorry again. I meant that I couldn’t download the ‘‘audio’’ files.

Nobuo has the same problem, but I can download Wildebeat…

I have the same problem. I had posted the same question on Ask the Tutor Forum, but I haven’t get any hint to solve this mystery.

Could somebody try it also? The Wildebeat - LingQ Language Library
Now we have 3 persons: 2 of them can’t download and only I can… I tried from 3 different computers - everywhere I can download.
Although I have problems with the first show when I use embed player – it speaks faster. But other episodes is played at normal speed

@ chikaraishihara, Cakypa, nobuo - This looks like it may be content hosted on an external server. To download this content you will have to right click on the Download button and choose Save Target as or Save file depending on your browser.