How to freely adjust the position of sentences and paragraphs?

I copy the artical from my Word document and TXT document, and generate a new lesson in Lingq. BUT, the paragraphs are wrong in the lesson. Some paragraphs in origernal document are merged into one paragraph in the Lingq lesson.
How to freely adjust the position of sentences and paragraphs?

origenal document:

import in LingQ:


You can edit the lesson that you uploaded: go to the menu (three dots in the right upper corner of the text), and then click on “edit lesson”.

I have done this but the problem still exists

You can’t do much. There are a few things that you can try, though:

  1. Copy text to MS Word first, then copy the text to LingQ. For some inconceivable reason, formatting and new-string symbols are retained, sometimes.
  2. Go to Edit the lesson → press the button ‘Show/hide sentences’ → now ‘Mark end of sentence’ button appears. You can put those marks in the text; nevertheless, it does not guarantee that the system would obey them.
1 Like

This is what I do, too. It sometimes works, but it often doesn’t. I haven’t figured out anything that works consistently for formatting.

I’m hoping that this is going to be fixed in the LingQ 5.0 update.


I will try it, thank you !

let me try, thanks~~

For Greek (this should work for English too), I usually copy paste the text in Pages (mac), then in the edit lesson. It works almost always. If not, I copy paste to TextEdit before (then Pages, then Edit lesson). Together, it’s fine for 99% of the cases, not factoring the splitting itself that Lingq does when you open a lesson (the visual one that can change on the options tab).

For Japanese the situation is much worse, the copy paste technique doesn’t work. So what I do is copy paste to Pages (or Word directly), then copy paste to Word and replace every paragraph end (^p) with (・・^p). This works much better with the lingq splitting function. If it doesn’t work, then in the edit lesson tab, I search for the ・・ and verify that they are at the end of the paragraph, or proceed to edit them manually. Then save and open. And if it still doesn’t work, my eyes associate the ・・ with a paragraph jump anyway.

As a side note, sometimes “saving” in the edit lesson, and THEN “saving & opening” fixes many formatting issues. Don’t ask me why.

Here’s what sometimes works for me when I want to make small changes to an article:

Go to “Edit Lesson”. Then on the left side of the page click on “Show/Hide Sentences.” You will notice that there are now red markings on the page that look like “[00:00].” Also notice the appearance of a button “Mark end of sentence” right below the title of your article. Place your cursor wherever you want the new paragraph to start and click on “Mark end of sentence”.

When you click on that, you will notice that “[:]” appears, rewrite it as “[00:00]” (make sure it is in red), and save. You should notice that there is a new paragraph (I sometimes have to play with it, but I always end up getting it to work, might take 2 tries though).

Lastly, you HAVE to click “Mark end of sentence”, simply typing out [00:00] will not work.

1 Like