Exporting Vocabulary

Hi guys, I was wondering if there was a way to export vocabulary elsewhere (e.g. to Anki). It would be very useful for further practice. There seems to be Vocabulary Import/Export section on LingQ but the export button is nowhere to be found.
Thanks.

After you choose some words, then the “export” function shows up under “More Actions” on the left side of the screen.

Thanks for answering. Is it possible that you have a different version of LingQ than me? There is no function called More Actions on my screen, even if I select a few words. The only option that becomes active after selecting some words is “My Corrections”. Here the functions listed contain: Status +1, Status -1, Example, Make known, Print, Import and Delete. That’s all. Any suggestions? Thanks.

Looks like you are looking at the wrong place. On the Home page, click on the Vocabulary tab and list of all your created LingQs will appear. There you will be able to select then and export them. You will find “More Actions” option on the top left.

I don’t know. I tried to paste in a screen shot, but I guess that’s not possible. My page says “Vocabulary” at the top, then “Filters” then there are several tabs which say “More Actions,” “All,” “Phrases,” “Due for Review,” and “Import Vocabulary.” Under “More Actions” the choices are the same as yours, but my last three are Print, 'Export and Review. If we’re on the same page then I guess the actions are different.

You can send us your screenshot to support(at)lingq.com and we will assist.

Thank you, I think the OP must have it figured out at this point.

Thanks, guys. Just a quick update. It was a language problem. My version says “import” but what it does in fact is export. To be honest, I would prefer to switch the language of the interface into English if I could to prevent problems like these but this is not an option on LinqQ as far as I know. The trouble is that the Czech interface is a weird mixture of English and Czech. And when Czech is used, the translation is not always correct.
Anyway, the exported file is useless I am afraid. The vocab gets exported automatically into an Excel sheet, in which all the words in Czech (my translations) are unreadable. The thing is that all the special letters in Czech are replaced with some non-existent signs.
Anybody experiencing a similar problem?
Thanks.

Sorry about that. We will do our best to improve all interface language translations, including Czech. For start, I will fix that wrong translation you noticed!
You can change your interface language to English if you click on the settings button right next to tabs on the Home Page. There you will find Interface Language option under home settings.

Other problem you mentioned with strange characters sounds like a coding issue.
After you download a CSV file from LingQ, close it and then create new regular EXCEL file. Open that new blank excel file and then:
Click on the DATA tab on the top and choose FROM TEXT option. Popup will appear and you should find your CSV file downloaded from LingQ, select it and click on IMPORT. On the next popup choose DELIMITED, click on NEXT and check TAB and COMMA options. Click on NEXT and then FINISH.
That should be it. You can then save the file again in CSV format if you want to import it somewhere. Hope this helps!

1 Like

Hi Zoran, I followed your advice about the strange characters in my csv file and it worked. Unfortunately, as it happens, more problems have cropped up.

Since comma is used as a separator, any time anybody uses a comma in their translation (and people often do) the text gets separated forming another line. So at the moment there is no way for me to have three neat columns. One for the original expression, another with translations and the third one with example sentences. Which is what you need to be able to import the vocab elsewhere, e.g. Anki.
The solution would be to use a less common sign as a separator. Can you do that in LingQ?

Another thing is that I am not able to select more than 200 expressions at once for export. Is there a way around it?
Thank you.

By the way, I have changed my interface into English but it keeps turning back into Czech. No idea why this happens.