Every lingq I click on is added to the vocabulary list

How do I turn this off so it will only add stuff I specifically put in there?

You can disable “Auto create LingQs” under the settings button (gear icon) on the home page, Reader Settings tab.

I have that disabled. Still creating links.