Error with TTS engine not being installed correctly

When I open app, I get “Text to Speech failed. Please make sure its installed correctly.” error.

I have Speech Services by Google installed and correctly used by other programs.

Any way I can solve this?

Can you check and make sure Google TTS is set as default on your device, under the settings?

1 Like

Yes, its checked. I’ve tried tts through Firefox and visited lingq through there. TTS works as it should.

I have tried this in Beta 5.0, and it’s working as it should, so this might not be a top priority. Just for information, I’m running Lineage 0S with MicroG. TTS was working till few updates ago. I can try to find the working build if you need the info.

Thanks for the update and thanks for testing it on the Beta version too. I’ll check this with our Android developers.

Hi guys, I have trouble with Lineage OS and Flite TTS (but without microG). I get the same error message as @christooss. Is it possible to fix this somehow without installing any google apps?

Is it not possible to install Google TTS on your device?

Hi, thanks for the fast answer. No it is not possible unfortunately. I am running Lineage 18.1
As an alternative to Google TTS I tried Flite TTS and RHVoice (both from F-Droid).

@montagsmodell What app version you have installed at the moment?

1 Like

My version is 4.9.22, taken from Aurora store.

can’t answer on your other post down below.
My version of lingq is 4.9.22, taken from Aurora store.

Please email me to support(at) and I will provide you with an APK file to install the newer version and see how it goes.

updating this ticket to let others know that it works with Lineage OS 18.1, Flite TTS, and lingq app version 5.2.22

1 Like