Error: Something went wrong Cannot read properties of undefined (reading 'findIndex')

Certain blue words in a lesson I imported are causing the error in the title.

Can you provide a link to a lesson? If you can also mention words in a lesson that cause the issue that would be great. Thanks!
If it’s a private lesson, you can also message me on support(at)

Hi Zoran

Lesson Login - LingQ
Words: Teknikfond and Skiften. I only got that error once when I tried just now but neither of those words will change from blue.

Can you please give it another try now? I tested the lessons and everything works properly on my end.

Tried it again and still not working. I cannot select a meaning for the word teknikfond or skiften in that lesson.

I noticed a pattern to when this happens, it is always after an image in the imported text. Not the word directly after the image, but somewhere in the next sentence or paragraph. I’ve had this problem in several lessons now and it always follows that pattern.

Thanks. Can you please email me, send some lesson URLs and please include a screenshot of a words you have problem with (with a page they are on), so that I can continue trying to reproduce the problem on my end. Thanks!

Hi Zoran, I think you must have fixed it because it is now working! Thanks

1 Like