Edit Lesson in new version of LingQ

In the previous version, you could click ‘edit lesson’ and see the whole lesson text in editable format. ‘Edit Lesson’ no longer works like that. Is it still possible to see all of the lesson text in editable format somehow?


Yes: click on the three dots in the right upper corner above your text, click on edit lesson, then scroll down. In the small window on the left side of the screen you see: regenerate lesson. Click on those words.


You can only see “Edit Lesson” for your own imported lessons. For lessons imported by other users, you can’t edit complete lessons, but if you switch to the Sentence mode, you will see “Edit Sentence” option under the menu. We changed this and Premium users can now edit separate sentences.

benscheelings you are right, thank you! I had seen that button, but the word ‘regenerate’ seemed rather forbidding for such a simple action, and my fear was increased when I clicked on the button and saw ‘Are you SURE??’ so I bailed out. But I’ve tried just now, and it works.


I had the same hesitations, Protorich!

Thanks very much for posting this reply mate

This is a good trick and exactly what I needed! I import a video, but that true transcript I get from elsewhere and need to overwrite the auto generated youtube subtitles.

What I’m seeing though is strange. When I pasted the proper transcript in and then view lesson (I see it saving), it’s back to the lowercase of the auto generated subtitles when reading. However, when I go back into Edit Lesson, it does show the proper transcript I pasted in. In fact, the “sentences” are there now. If I click back to view lesson, or even go all the way out and view the lesson from another “vector” it still shows the auto generated text. Still, I go to Edit Lesson and it has the proper transcript. I tried regenerating again but that didn’t help. It may be caching in the web is all I can think of, but if I go to the app it is showing lowercase as well.

I know I’ve done the above before with something else and eventually I got it to work right. Maybe it just takes time???

All day yesterday and in all apps, after regenerating lesson and replacing entire text, and then viewing (which does a save), the reader view was showing the old text. HOwever, the edit lesson view would continue to show the new transcript when I’d go into it.

This morning, however, even in the Edit Lesson view it had reverted back to the old transcript.

I’m wondering if this is because the words probably more or less matched one to one, except the new had the proper capitalization and punctuation?

So just now, I went to edit lesson. Regenerate Lesson which gave me the full editable text and deleted it, except I left one word (just in case it would complain if there were no words). I then clicked “View Lesson” which saved it. Reader view now had this one word. I then went back to Edit Lesson, Regenerate Lesson, and then replaced that text with the proper transcript. Then clicked View Lesson which saved. Now the Reader has the new transcript and all apps are reflecting this as well.

So, a bit of a roundabout way and maybe a bit of a bug if the sentences more or less match it may not be working right with that.