Do you All Distinguish External Links Published in This Forum?

I often don’t see any link on iMac when posted in this forum. I see them sometimes in blue color when the dark theme is on otherwise I just don’t see them. They are exactly like every other text.
Is there any setting I should change?
Chrome / iMac


Hi @davideroccato,

Usually, URLs/Links will automatically change to blue/“highlighted boxes” when they’re recognized as clickable links.

But just in case, every time I post a link, I always highlight the entire link, then link that link to itself to be sure it shows up properly. Since some of the ways 3rd party links and forum links are displayed are a bit different from how I have seen in other forums that use the Discourse platform work (a.k.a. automatically turning links/URLs into clickable links and forum posts on their own line into highlighted text boxes, etc.*).

(Note: Though they actually seem to finally work here for me, lol — see below examples — so maybe they updated since I tried this last.)

Example of a “highlighted box”/generated preview:

Example of linking a link to itself:

Example with a link detected after text:

Within the Forum, I will also link text to other text like this:

Discourse Plattform

Did any of the above examples not show up when viewing on your iMac?

P.S. I have a Mac (not iMac) and use Chrome, but I use it in a dark theme. No problems with links (other than what I already mentioned).

P.P.S. How these types of links/URLs show up on my computer:

1 Like

@jpp025 Thank you for the test. I can see them only with the dark theme. The screenshot below is how I see your text during the day with the light theme. Basically I can’t see any of them.

1 Like

Ah, yes, thank you for the screenshot!

hmm…maybe another user has some insight on any settings you can change for your iMac.

I agree; that’s pretty impossible to see unless you hover over the text (by chance) or see a link with https.

Edit: P.S. I changed my interface for the forum (via the interface preferences on the LingQ forum) and got the same thing as you, btw:

Note: Forum interface settings set to “Light”

This is what I get when I set the forum to “Solarized Light” mode:

Note: The blue links show up.

It’s something with the settings for this forum in light mode and how it interacts with URLs, I think.

I swapped to Dark Mode and post all links in bold tags ** [Link Name](Link Address) **
Google Home Page

Dark Mode settings can be swapped here → change ‘yourname’ with your name

1 Like

@jpp025 That is exactly how I see the forum with “Light” settings. Thanks for the tip, I didn’t remember there were those settings.

@roosterburton thanks for the screenshot but there is some other issue.

I have something weird now, I’ve tried to change those “Regular” settings for another color but the color changes only in that setting page. ALL forum stays with the same Light. I cannot change to Solarized or WCAG Light for the rest of the forum. I quitted Chrome but nothing changes.

No clue at the moment, I’ll have to dig more why that’s happening.

In any case, I should be able to see all links in blue even with the Regular Light Theme. This does not make sense. Is it a problem of the forum platform itself or some LingQ tweaks?

@davideroccato I figured it out! :smiley:

These settings will get you a light mode that will show you the URLs in blue:

Screenshot of WCAG Light Mode

Edit: For other users this may help, make sure to scroll and hit “save changes” at the bottom of the page to implement your new settings:

Additional Note: As davideroccato shared you don’t have to change the dark mode setting to get it to work for you :smiley:

Likely, the regular “Light” mode is for the highest accessibility — as a white background with black text is of higher contrast than a white background with blue text.

WCAG mode gives you that blue for links, and not everyone can process blue (e.g., colorblindness). But this is just my best guess on the “why” of it.

1 Like

@jpp025 I got it, thanks. I knew there was something stupid, I didn’t click “save changes” in the WCAG Light configuration. I keep the Dark mode as Dark and it’s working now.

Thanks for your help. I can see blue > everything blue now, including buttons and all the rest. :smile:

1 Like

@davideroccato, Nice! Good to know. (I added a screenshot of the button to my previous reply and linked to your reply there, too, so it can benefit any users that come across this topic in the future with similar questions.)

Glad it’s working better for you!

1 Like