Dictionary problem

I use the classic version, because the Babylon dictionary gives me by far the best user experience for English to German.

After a short break (2 or 3 weeks) I came back today to study a new lesson. But the English->German dictionary of Babylon is no longer there. Instead there is only English->English for Babylon in the “Edit dictionary settings” available. Haven’t you told us, that the functionality of the Classic version will stick?

The Babylon dictionary is the main reason for me to use LingQ, and to use the Classic view, because it is not available in the new view. I don’t trust the user hints, because I’ve seen a lot wrong user hints. Also I like to see if there is more than one definition for a word. And I like to see the grammatical form of the word. Also it is very easy to copy the definition form Babylon. Copying from other dictionaries is often difficulty because there are links included in the definitions or other things, so I’ve to type the definitions by hand, which is quite inconvenient.

Please, would you bring back the English->German Babylon?

Here is a screenshot: https://www.screencast.com/t/O4xWXRPB

1 Like

5 min ago Zoran wrote that “reactions for New Mode were extremely positive” )))

As I understand this Vera’s letter is the example of this “extremely positive” reactions.


And Zoran, take into account that Vera is the real pillar of LingQ (Deutsch part as minimum), not you, not your designer with inflamed imagination.
When you invent something new - ASK THE SUBSCRIBERS - are they need it or not!

Yours, Denis

1 Like

Sorry about that Vera, we will get it fixed.

Thank you, Zoran. Is there any time schedule?

Hi Zoran, When will it be resolved? I want to read an English book with LingQ, and I prefer Babylon, because it is much easier to handle.

1 Like

I just went to take a look at this and that dictionary is working fine for me. Are you sure you have German selected as your Dictionary Language?

Thank you, Mark. That was really strange. The Dictionary Language was English, but I’ve never changed it in my settings. How could that happen? When I changed it into “German”, I had acccess to the German Babylon. Strangely the other dictionaries that you can see in the hardcopy above were no longer there, but I was able to add them again.

I’m not really sure. It must be that you changed it for some reason at some point. I don’t think it could change in any other way. But, if it happens again let us know and will try and figure out what could be happening there.