"delete lesson" does not work

From Learn menu, select “My Lessons”
For the lesson you want to remove, click on gear icon
Select “Delete Lesson”
Click “OK” on confirmation popup

Refresh/reload and lesson is still displayed on the “My Lessons” page.
The lesson is still there 2 days later, so I don’t think it’s a queuing delay.

Sorry about this! It seems that you are right, I was able to reproduce this issue. Our development team will take a look into this and I hope that they will fix it soon. I’ll keep you updated!

Hi xophist,
Just to let you know that this issue is now solved and you should be able to delete lessons from My Lessons page.
Thanks for your patience!

Thanks Zoran.

Hi again,
I’ve just replied to your email to support. Your screenshots are helpful and we are looking into that issue too. We are doing our best to fix it soon.

Re the “delete lesson” problem, it doesn’t look fixed to me.

I just now selected “My Lessons” and from the gear menu selected “Delete Lesson”, then clicked OK on the “Are you sure?” popup.

There was no change in the webpage, so after a few minutes I reloaded the page and the unwanted lesson is still there.

The lesson I tried to remove is in my Chinese list: “Useful Apps when Traveling: Chat Radio Transcripts - Mandarin”

I had the same problem with other languages and lessons.

Hi xophist,
Sorry about that, I’ve just checked this and it seems that this fix will be pushed to the server shortly.
Fix should be applied during next few hours.

Thanks again.

Is there a webpage showing open issues and statuses?

I have a few minor issues to report, but I don’t want to open threads if these are known issues and listed on a status page.

Unfortunately we don’t have page with list of issues available.
If you have any other issues on site, feel free to let us know on our support email and we will follow up from there.

Zoran, it’s about 20 hours later, and still the “delete lesson” problem is not fixed, so there is something else in play here.

Fix has been applied. I have just checked this and it works fine for me. I am able to delete lessons from “My Lessons” page.
Please check again. If it still doesn’t work, clear your browser’s cache and try again.

I’ve previously cleared the cache and that’s not the problem.

I’ve created a new thread to highlight that the problem was fixed except for the case where the lesson originated as an imported lesson.