Default dictionary doesn’t work

I’ve noticed by LingQing that the default dictionary (Babylon) doesn’t work automatically anymore; I have to click on it or on another one. Is it a bug or changed intentionally?

@ junair - That is a bug we are working on. We should have it resolved soon.

On the positive side, this bug has made me realize what a great dictionary Google dictionary is. I usually have two monitors when I work on my computer, and the google dictionary translation pops up right away on my second monitor. The google dictionary also does phrases.

yes, Google is good- but at some phrases and sentences translation you can get rubbish as well.
I’ve tried to set Google in Dictionary Settings but it doesn’t work. OK, I’ll wait til the bug is fixed.

Did you set Google Dictionary as your default dictionary in settings and it did not work, Junair?

I found out it doesn’t work in Chrome but it works in IE8.

I have the same problem with IE7. In the past the suggestion of the dictionary was automatically shown. Now I have to click on “dictionary” to see the definition. I hope you’ll find a solution soon. It think it can confuse new members a lot. Babylon is my default dictionary.

I am having the same problem as Vera, on Firefox.

I prefer Babylon as the defaut dictionary as well. It’ll be good to have it back once the bug has been fixed.