Cyrillic Font Issue

Normally I work on LingQ on my iMac desktop, which works quite nicely. However, I just acquired a pre-owned iBook G4 laptop. When I pull up LingQ on this machine, I notice a strange situation with the fonts in the lesson transcripts (I am currently working on The Story of Nina - Russian version.) The lines which are in bold print are just fine, but the lines which are not in bold are displaying in a sort of “italicized” style in which several of the Cyrillic letters are more related to those in the cursive handwriting script. For example “t” is given by the letter “m”, etc. I have tried using both Safari and Firefox browsers, with no difference in the result. Any idea where I might go to change the font style for the way things appear on LingQ??

Perhaps some font is missing and Mac OS substitutes it with the next available one in described in the CSS file.

I’d have to know more about your configuration, though: OS version on the iMac and the iBook for starters. Which version of Safari does each machine run? Which fonts are you seeing on each machine?

That last one is easy to determine. Just copy some text and paste it into TextEdit. Then hit Command-T to bring up the Fonts panel and it should tell you the name of the font right there.

It gets complicated. First the easy stuff: the iMac is running Tiger OS and the laptop is running Leopard OS. Both are running the latest versions of Firefox for Mac (ver 3.6.4). iMac has Safari 4.0.4, and the iBook has the upgraded version 5.0 for Leopard.

As to the fonts… it is tricky. As you may have found out, one cannon copy text from the LingQ transcript pages. True, you get the blue highlight, but Command-C will not copy it. Must be because of the LingQing system of known vs unknown vs LingQed words. I can however copy-paste from the version of the transcript used for printing. I have noticed something else, however. It only seems that when a third party or speaker is introduced to the conversation that the itlalicized font is used… like with Mama, or the stewardess in Lesson 24. In the printer version, you can see that these lines have a slight tilt to them (italicized) compared to the text for Nina’s lines. However, when I copy-paste them to Text Edit, Command-T tells me that both are Times-Regular-12. So now I am even more confused!

And who can help me with french letters with ‘caps’ like е in “etre”?
I have separately ^^, but I can’t combine it with е, u; a; I receive ^^ee^^e^^e^^e^^e^^e^^eu^^u^^ua^^a^^a. What to do? The same is with ¨¨I¨¨I¨¨a¨¨Aa^¨¨¨¨¨¨Ii¨¨ - always wrong!
How can I create these french letters?


You can update Safari to v4.1 on Tiger. This will make the rendering engine a little more on the par with v5.0 for Leopard and later.

You’re right, I forgot that LingQ uses JavaScript for displaying text in lessons. Let me see if I can find some meaningful info in the source code.

Okay, they seem to be listed in the following order: Tahoma, Arial, Helvetica. Now, Tahoma is a very poor choice. For one, it was intended to be a system font for Windows OS and as such doesn’t have the italic version. I am also not sure if it comes bundled with Mac OS 10.4 at all.

Arial is a pretty ugly knockoff of Helvetica, but it comes standard on all operating systems and is usually a safe choice. (Although, I’d switch Helvetica and Arial around in the CSS so that Helvetica came first.)

But let’s do some testing, shall we? Of the two fonts—Helvetica and Arial—it looks like its the latter that uses a completely different italicized version of Cyrillic characters, and that’s probably what you’re seeing on the iBook.

Download this file and open it in TextEdit on each machine:

Could it be that you don’t have Arial installed on the iMac?

Well? Any news?


What is your OS? if it is WIndows you can change the keyboard layout to a French one when you type French.

If you are not technically minded I think you can use Google docs to type in French without accents and then use a French spell check that will put (most) of them in for you. LingQ’s French spell check might do that too. The rest of them you can put in with Insert> Symbol on the Word editing menus.

Thanks, dooo,
I’m really a very unskilled person in technic, a 100% philologist.
My friend helped me yesterday, at least, if I use a Word, I can create all french letters.
By the way, I would like someday to sign up for one of your discussions, but your schedule falls always on my night.
My time zone is GMT+4.00.

Various things make my current times the only possible time I can tutor. I wish I could do more…

Evgueny - Do not put accents on french caps. Accents on french caps is a computer creation. in therory the accents do not leave because letters are caps but in practic - we do not print any accents on caps. There is now french keyboard that I know where you can type an accent on a cap. The only ways to put accents on french cap is either to use a computer formula, something like Eacute; or to use a virtual keyboard - no french native will use those solutions.

Before computers the typemachines did not allow to print of accents on caps. Eacute was theoritically possible but you had to put a coma on the previous line just at the good position for the coma to figure the acute - of course noboby did that. For other accent it was impossible or for some accents they were hidden in the caps letter.

Accents on french caps is caligraphy.
There is no way to misunderstood french because accents are missing.

@ astamore
Sorry for delay; didn’t see your post. Test results: When the file is opened on the iMac it shows this:
Arial - letters not italicized (leaning), perfectly readable
Helvetica - letters are italicized, but are perfectly readable, ie no cursive style scripting

Then, on the iBook what I see in TextEdit is:
Arial - italicized AND scriptish, with the cursive mutations
Helvetica - italic (leaning), but perfectly readable; not scriptish

I hope this info helps. Looks like I need to something with the iBook’s fonts, but what???


Not much you can do about it, really The iBook (or, more precisely, Mac OS 10.5) displays the document correctly. The iMac (or, rather, Mac OS 10.4) does not, because it doesn’t have Arial (and substitutes it for something else).

The best solution would be to ask the web admins on LingQ to fix the CSS properties by putting Helvetica at the beginning of the list and put Arial at behind it.

The not-so-good-and-quite-prone-to-some-nasty-things-but-oh-maybe-okay-for-now-or-at-least-let’s-hope-nothing-breaks solution for you would be to disable Arial on the iBook.

  1. Launch FontBook (located in the Applications folder in the root of the hard disk).
  2. Select Arial from the list of fonts. You can type Arial in the search field to filter out the other fonts. This will help narrow the list down.
  3. Choose Disable “Arial” Family from the Edit menu.

This should take effect immediately as soon as you reload the page in Safari.


in evgueny’s post “caps” =! “capitals”, “caps” = “hats” ( which some of the French accents resemble)

You are right dooo.

What I do for spanish is using a virtual keyboard. There is a french one at

you can save it and use it offline is you want. I would not use the accentuated caps or the ae and oe.

There are virtual keyboards in many languages at this address :

Thanks a lot, Dooo and Pierre!
Now I’m going to write French more than before!
Merci beaucoup!

@Miss Take,
Je ne pence pas cela, mon ami a expliqué que il y a une redaction russe sur mon ordinateur. Il a rajouté la redaction européene et maintenant ce travaille bien (j’espére : pour toujours).
Toutfois, merci pour la sollicitude!

OK, so if Mark or someone from LingQ has been following this thread, can astamoore’s suggestion be implemented to solve problem for me, or would that just cause problems for others?? Otherwise I will have to try his Plan-B, disabling the Arial fonts on my laptop. Here is what astamoore suggested:

"The best solution would be to ask the web admins on LingQ to fix the CSS properties by putting Helvetica at the beginning of the list and put Arial at behind it. "

Thanks, Banjolover (Misha)

I don’t fully understand but wouldn’t that change the experience for the majority of LingQ users who would now get Helvetia. Or, is that not the case?

Well, here’s what it breaks down to.

  1. Windows users don’t have Helvetica installed by default (Helvetica doesn’t ship with Windows).
  2. Mac OS users will, indeed, see Helvetica, instead of Tahoma and Arial. Mac OS users are, by far, not the majority here.

In terms of user experience, Helvetica is a much better choice. The font is considered one of the best fonts (if not the best font) of all time.

Of the three fonts that you use—Tahoma, Helvetica, and Arial—only Helvetica is available to all Mac OS users. Tahoma began shipping in Mac OS 10.5 and I’m not sure about Arial.

As I said earlier, Tahoma is a poor choice. It was intended to be a system font for Windows OS and as such doesn’t have the italic version. Much like Arial is a Helvetica knockoff, Tahoma was “based on” Frutiger, a highly esteemed font among designers. Tahoma, however, was designed as a bitmap font and has neither a true italic nor bold versions.

I’d probably do it like this:

font-family: Tahoma, Helvetica, Arial, sans-serif;

This way Windows users and Mac OS 10.5 and later users get Tahoma, Mac OS 10.4 and earlier users get Helvetica.

or, better yet,

font-family: Helvetica, Tahoma, Arial, sans-serif;

This way Windows users get Tahoma and Mac OS users (regardless of which version of Mac OS they are running) will get Helvetica.

It’s a simple and painless change to the stylesheet. If something breaks, you can always change it back.

It is possible to create more than one style (css) for a web page and users are able to change the css if one create problems or if they prefer one other. On french firefox Affichage -Style de la page (display-page style) there is also the possibility to display the page without any style.

If a font is missing on your computer it is possible to download it - but I do not know the exact procedure for this.