Create a .csv file

I have a .MEM file from a flashcard app I made before I found LingQ. Is there any way I can convert the .MEM to a .csv to add to my flashcard pile at LingQ?

Import into Excel/OpenOffice, make the pertinent changes to create the LingQ format, export as CSV and import into LingQ.

when you say make the pertinent changes to create the LingQ format, what do you mean?

Column 1, 2, 3 = word, hint/translation, sentence

That doesn’t work for me.

I’ve edited a spreadsheet manually, saved it as a csv and get three fields, of which the first included word+hint+phrase…
When save the same file (choosing .csv in the format dropdown menu - it really shouldn’t matter…) I get nothing.
If open a tabbed .txt file in Excel, save it as .csv (by choosing the right format), I also get nothing. Only a Javascript error:

“Meddelande: ‘)’ förväntas
Rad: 1
Tecken: 49
Kod: 0

I’m SO tired of trying to get things to work here.

If you have a worksheet with 3 columns (word, hint, sentence), then you are able export it as a CSV file (with charset=UTF-8 / field delimiter= , / text delimiter= " ) - then it should be possible to import that file into LingQ. NB: The length of the fields should not exceed 250 characters.

It SHOULD be possible, yes. I haven’t yet succeeded, though. Part of the problem might be that Excel itself doesn’t ask about the encoding, who knows. However, csv is an old format, and should really be foolproof.

Now I tried again, with a manually edited txt file, saved as csv. ONE LingQ was imported (all info in the correct fields, though).

Same file, open in Excel, saved as csv - no LingQs inmported.

This is really annoying since I could save SO MUCH time if could copy the Quick LingQ list, do some minor editing, run the words in Google Translate*, copy/paste, import. But I can’t.

And they ask why members don’t create more LingQs…

*Why Google translate? Well, because a hint only shows up every 200 words, and I have to use an online dictionary anyway. Why not run the whole list through it to save time.

I use OpenOffice, and it works the way I described.

My work computer actually has OpenOffice! New attempt:
“Error: line contains NULL byte”

I had a similar problem with importing lists in Russian. This works for me: I save my list in Excel as a “.csv” file. Then I open the file in Word, and save as a “.txt” file. As part of the save process, Word allows me to choose the encoding, and I pick Unicode (UTF-8). Then, in Windows, I change the name of my file from, for example, “vocab.txt” to “vocab.csv”, and this file will load into Lingq.

I created a small screencast: How to import from OO into LingQ

(1) I prepared a spreadsheet in OpenOffice with 3 columns (word, hint, sentence).
(2) I export this as a CSV (with charset=UTF-8 / field delimiter= , / text delimiter= " )
(3) I show the file in a text editor: it contains one line:

“舅父”,"jiùfù = mother’s brother; uncle ",“每天傍晚舅父都会陪着舅母在海边闲步。= Měitiān bàngwǎn jiùfù dōuhuì péi zhe jiùmǔ zài hǎibiān xiánbù. = My uncle goes to walk with my aunt by the sea in the dusk every day.”

(4) I import the file into LingQ - Success.
(5) I show the LingQ.

Hope that helps.

That’s a very good screencast. I did exactly that earlier today, but got the “Error: line contains NULL byte”.

Jeff, were you able to solve you export/import problem?

I haven’t tried again. I just don’t get it. The video clip provided the step-bystep instruction which I had figured out myself (using Open Office at work), but it just didn’t work - “Error: line contains NULL byte”.

At some stage (using Excel) I managed to import ONE entry (the file contained five-six dummy LingQs). If that’s all it can do, I can continue saving one LingQ at a time.

Is it absolutely necessary to have info in all three columns? I have information saved in two, and when I attempt to upload it, the progress bar runs through and then nothing happens. Not even an error message. :S

I can’t convert my MEM file but I am not going to bother now anyway. I know for sure now that I want a mac!


Why do you think a Mac can do this better than an Windows PC?


The upload of 2 columns: “舅父”,"jiùfù = mother’s brother; uncle "
works also without any problems.
BUT: If one field ist longer than 250 characters then the upload crashes without any further error message!

Sorry, I meant that I want a mac because they look quite cool! The whole interface is a lot nicer than windows.

@hape. So I have to put each entry in quotation marks? If so, that’s probably what I was doing wrong! I’ll have another go. Thanks.

Quotations marks or not hasn’t changed anything for me. At the very best, I got ONE entry (following hape’s method step-by-step), despite that the file had several entries.