Course editing - server error

Since today’s update I can’t add an image or keywords to an existing lesson. I also can’t mark a completed course as shared…

I recently also tried to submit an RSS feed to iTunes and Apple now requires a 4000x4000px image. Perhaps a default image could be used in the RSS feed as such big images are hard to find…

1 Like

…and adding an image to a lesson and then marking it as shared brings up a new dialog
“Do you want to post this lesson on the to RussianLingQ Twitter Feed to share this lesson with the World?” but if you say no, nothing happens…

Note there is a typo in new dialog “Do you want to post this lesson on the to RussianLingQ Twitter Feed to share this lesson with the World?”

“on the to” should be “to the”.

I’m off to bed, many new lessons to post tomorrow :wink:

I cleared the cache (chrome on mac) and tried another browser (safari on mac), but these issues still persist.

It doesn’t prevent studying, so I’m happy for now!

Thanks for the heads up, and sorry for the delay in getting back to you! We’ve been working hard since the update to fix issues, and in the process didn’t even notice that some forum post notifications weren’t sending properly.

Would you send me a link to the course which you’re having issues with? We’ll also take a closer look into the sharing issues you reported and will get those fixed!

Thanks, keke! I’ve fixed that now.

1 Like


I’ve sent a link to the problematic lesson as a private post on your wall. From memory I added the material immediately after the site went live again after the recent update.

Thanks! I’ve been able to reproduce this and one of our devs is looking into this now. We’ll hopefully have it fixed by the end of the day, so I’ll let you know when this is ready to go!


Should be fixed now, please give it another go and let us know if you run into any other issues here!

(Oh, and I’ll make a note of the RSS feed, though I don’t know if the image on our end would be large enough either - 4000x4000 is huge!)

I am having the same problem for spanish lesson posting. I think it is not fixed yet.

Looks like it’s working again. I successfully published the course that I was having trouble with.

When publishing the course as a whole, there was no “tweet this course” option. It may be worth tweeting my new course while it is still topical, but I can’t seem to do that - is it only for lessons?. See Ask your tutor (Russian) forum for more information.


p.s. yes, weird new huge image requirements, Apple is getting ready for 4K, the next Apple TV and everyone with retina displays.

My problem persists, I cannot share lesson in spanish part. It asks me whether i want to share the content on twitter but when i click the buttons althought the question closes, the material does not update.

The lessons i create can’t be viewed in android application. I am not sure about reason. It can be either because they are not shared lessons or the android did not update the course material. But i suspect latter is the problem. Because when i listen material on my android my statistics do not update, hence i believe that, currently android libraries are not updating.

Sorry about this! Would you please let us know if you still have problem with sharing lessons? Can you please provide us link to a lesson so that we can try to share it? I’ll also check if it show up into LingQ app.