Course doesn't show all lessons

In my self-created course appear only about 15 of over 50 lessons when I open it on my desktop. In my Android app everything is messed up. It seems like the single lessons are still there, but they don’t show up (or in a messed-up order) in the course overview.


Can you please post a link to that course? Thanks!

This has happened to me, too (I see a few other people seem to be having the same issue). One of my imported courses (all private) shows the 11 lessons I imported and edited to near-perfection, but only 8 are available (via the normal screen) on the web. The other 3 don’t show up on this screen, no matter how I try to view them (all, oldest, newest, etc.). Luckily, they are all still available on my Android tablet, AND I was able to access them on the web via a few other screens (one is an editor for all my courses, which I just stumbled on). It’s more complicated even than that, but here’s a screencap of the course page to start, if it helps.

1 Like

Hi Zoran / LingQ Team

Same for me since yesterday, only two of eight lessons showing in private course, edit course list shows eight lessons ok, but Library view for this (Norwegian) course that I’m working on only shows 2 Lessons listed … (Win 11 laptop, Web Edge browser)

Thank you, FrankG


We are looking into the issue. Thanks for your patience!

1 Like

I had the same issue with only some lessons showing in a private course I made - and also with not being able to upload mp3 audio to a new lesson I was trying to add. I tried again a couple of days later on my Chrome browser instead of the Safari browser I had been using and everything was fine. I’m hoping it was a simple as that and that Chrome will continue to work for me.

I get the same problem.
I do some lessons, when laying in bed, in the morning, on my Android, and it does not get included on to my Laptop, so sometimes it say’s I have missed a days worth of points.

A temporary fix I found is to change the level of the lesson to a different lesson. To resolve the issue, I went to edit the course and I changed the level from Intermediate 1 to beginner 1 for all of the lessons and I also set the privacy settings to private lesson again. This seemed to fix the issue. You can change the lesson level back when you’re done. If there are some lessons that it doesn’t work for, you can do the fix for those lessons individually.


Brilliant. I changed all of mine to the same level, and they all show up Thank you!

it seems to work but with more than 50 lessons in my course I would appreciate if this bug just get fixed.

1 Like

Super … that little trick worked for me too … many thanks :slight_smile:
Br, Frank