Can't unhighlight words I know

So lately I’ve noticed about 90% of the time I try to click on a word that I know to unhighlight it, absolutely nothing happens. This was never an issue before but for some reason it hasn’t been working correctly. I tried it on different browsers to see if it was a problem on my side but it’s the same. Anybody else experience this problem and if so, any solutions?

I am sorry to hear that you have problem with this. When you click on blue word what exactly happen? Are you able to click on “I know this word” button on the right?

Yeah the pop-up comes up and I click “I know this word” button but nothing happens after that. It’s weird though cause usually when I open a lesson it will work for the first three words or so but after that none of them work. It doesn’t bother me that much but its just kind of crowded with all these words highlighted I know.

Hi again,
Thanks for additional informations here. Few more questions. Do you have this issue with specific lessons only, or it happens with every lesson you open? Which browser are you using and does it help if you clear browser’s cache?
If clearing cache doesn’t help, would you be able to try another browser and check if it works? That will help us to find out if issue is browser related. Thanks!

My daughter had recently a similar problem. She tried clicking on one of the offered hints and nothing happened. It looked to me as if LingQ would stick or were really, really slow. Only after refreshing the screen LingQ worked again for a few minutes. She had to do it 5 or 6 times during one lesson. It was very annoying.

P.S. This happened on Monday with Firefox on Windows 7.

Exactly what happened to me earlier today (or yesterday of your time) although I used a different browser! Everything is sticky on the lesson page. Extremely annoying.