Can't import a cvs list

I’ve created a cvs list in a txt file, containing around 40-50 lingqs from a text I read outside lingq. I’m trying to import this file to my French vocabulary, but the only answer I get is an endless “processing” window. Two nights ago, I did let the computer turned on during the night, because I wanted to sleep without interrupting the process and, for my surprise, in the morning the page was still showing that “processing” window!!!
Of course I restarted the computer and went to work. I tried to do this both from ubuntu and windows 7 (firefox), and my new words simply don’t appear in the vocabulary section, no matter how long I wait for that outrageous “processing” little box.
By the way, it is running right now again, and it is again taking much more than it would be reasonable for such a small file to transfer. (Yes, my connection is ok for everything else).

Ana, can you send me that text file to support at That will help us figure out what the problem is.

I tried to use the export function in the vocabulary to create an Excel file . But the cyrillic was goobledegook. Otherwise my Excel is fine with cyrillic font - I can import cyrillic from another file eg Word and it will paste in ok.And I can paste in cyrillic into the Excel file created by LingQ.
Can you suggest how to fix this?

Martin, check that the encoding when you open the file in Excel is set to UTF-8.

Mark,thanks but I 've been through all the menus and I can’t see where to set the encoding. In Excel 2000 how do I set the encoding to UTF-8?

Martin, I don’t really know. I don’t have that program, however, are you not asked to choose an encoding when you first try to open or import that file? One other thing you can try is to use Google Documents. It’s a free program, you just need to sign up for a Google account. Then, you can import this file into Google Docs and see if it works there.

Yesterday I had a CSV file I downloaded from Lingq that I wanted to put into another language slot. I tried to import with Firefox, and I had the same problem as the original poster. However, when I came home I tried Safari instead, and it imported fine. So, OP, if you have another browser you might try that.

Mark,now I’ve tried using Excel 2007 and this worked fine. On this version it does ask you to choose an encoding when you import the file. So now I’ll use Excel 2007 and forget about the earlier version! Thanks for your help.