Cannot approve new posts

I have just attempted to approve a couple of new topics, but get an “Internal Server Error” message each time.

I experienced the same phenomenon last night.
I tried several times and was able to approve the new post that had been awaiting moderation.
But the thread was still in yellow on the list “Recently Active Threads”.
(I suppose the color means the post is awaiting moderation. Mistake In Lesson - Language Forum @ LingQ )

Strangely, the new thread, the first post of which I had approved, disappeared from the list and from the forum. WHO deleted it? Was it spam?
“Trick Question: On a scale of 10 to 11, what is the value of 9?”

I posted a comment in the thread:
“‘Catastrophic’ is the right word. On the scale of 1 to 10, this is an 11.”
Is this what you are referring to? It might mean “beyond measure”.

On the scale of 1 to 10, a zero could be an “NA”, which means no answer.

On some occasions, 9 or 99 means “Does Not Apply”.

Cannot approve this post.
Now I was able to approve the post, but it is still in yellow on the list.

I have had for a week or more the problem that the sidebar in the forum that shows the most recent active threads tells me that there are lots of threads with posts that need approval, but when I check them, there are no new posts inside. For example, here is my current view.

I can’t find posts that need to be approved in any of these highlighted threads.

1 Like

I’ve reported the problem that the thread stays yellow some days ago via email.

What the hell are they doing?
(I have been waiting a long time for the occasion to use this interesting phrase I learned.)

I may be wrong, but I think one reason for the threads staying yellow at the moment is that the originator of the post has only posted once. So at the moment the rule seems to be “first post needs approval and will stay yellow until second post”. (The bit with the second post removing the highlight is pure speculation, as is the bit in inverted commas.)

I am already disorientated, but you are in an alert state of mind even in this notorious enigmatic labyrinth named LingQ. Your testable hypothesis is worth checking.

We’d have to entice the respective originator of each post to add a second comment.

By the way, the “Approve Topic” button again generated an “Internal Server Error” a couple of minutes ago on two different threads.

Thanks everyone for letting us know about this. Vera has already reported it on support email yesterday, and this is added to our list and should be fixed soon.

@Yutaka Haha, nice one! If you continue to learn phrases similar to this one, I think that our administrators/developers could be in trouble! :slight_smile:
We are working on this, should be fixed soon.

I’m still not able to approve threads.

Like you I just tried to approve a thread. It is the “in der Überschrift” thread and I got the “Internal Server error”. I now know that that means the thread is being processed in the “Approval” queue (someone else has already approved it once - in this case you, I suspect.). The process is quite slow, but the initial action of approving will in the end lead to the thread appearing as approved. We just need to be patient…

So a new thread gets posted by a new user and it need to be approved. Moderator 1 goes in and approves it and no error appears, but the thread doesn’t appear as approved immediately, but instead takes a bit of time. During this time, Moderator 2 goes in and tried to approve it and they get the “Internal Server error” message. Is this how things play out?

Exactly! Ganz genau.

And sometimes Moderator 1 goes in more than once and gets the error message, then Moderator 3 comes and gets frustrated and, and, and.

See the last few posts in the following thread:

We are really sorry about this. We will get it resolved early next week.

That is exactly what happened to me. I wanted to add an answer after the approval and got an error that the thread is not approved. Than I tried again to approve it and got an internal server error.

I’m looking forward for the solution.