Bugs in the New (June 17) Interface

I am still loving the new design, but thought I would start a thread for the inevitable small difficulties which appear.

When I work with the flashcards, and I try to modify one, I can’t seem to get the “MODIFY” link to work. I am using Firefox and Windows Vista at the moment.

I think you mean Edit, and yes there is a problem using Edit from the back of the card. Try it from the front. We are going to fix this.

And thanks for starting the thread. A good idea.

I look forward to exploring the new features later; now I just want to report that this morning’s external link from the e-mails does not bring me to the Flashcards but rather to the new “Home page”. The Url gets changed to “Login - LingQ and Login - LingQ”, respectively. How do I get to the e-mail content?

  • I miss myself in the rankings.
  • In the blog list are blogs listed of people who are not my friends. By the way, maybe the list can now be a bit longer? I’ve so many friends that I sometimes miss there blogs.
  • How can I access the welcome page when I’m on another page? Is there a “hidden” link?

Not a bug but seeming strange for me is the layout of the friend page. Usually, there are submenues and there are the submenues “profile, Invite, Recommondations” in the friends menu. But when you click on friend there are now different sights with “Activities”, “Blogs” and “Ranking”. I understand how it works but I think you should have “one line” that you follow as we would say in German.

The fact that we cannot see ourselves in the rankings is an oversight that will be fixed.

The blog list on the Friends page can be controlled by the filters on the right; friends only, certain countries only, certain languages only or any combination of these. We could default to the friends view perhaps. What do others think?

The former Welcome page is basically just the top “Lessons” Tab except that the Friends activities have been moved to “Friends”, and the “Friends” tab will take you to an expanded version of the d “Community” Page.

I think that it will take a little time to get used to the new layout, and to iron out the problems. Please keep the comments and questions coming.

Yes, you are missing from the rankings for some reason on your own Friends page. We will get that fixed. I’m not sure why that was done. :stuck_out_tongue:

Vera, if you have All members selected in the group filter at right, you will see blog posts from all members. Change that filter to Friends to only see those of your friends. We probably won’t make the list longer since that will just make the page take longer to load. We may look into a “next” link to see another page of blog posts.

The Home page is now the page that shows up when you click on Lessons.

SanneT, we will look into that. Are others not able to open flashcards from the email as well?

Thank you for your fast answer. Yes, it need some time to get used to the new layout.

one word: magnificent

I have posted one little grumble on the thread Mark started: if I filter my friends on the language they are studying (eg Russian) then it is because I am interested in their Russian activities. I want to be able to see their activity scores in Russian, the Russian lessons they are studying and the Russian conversations that they have signed up for. Jeff is a powerhouse of LingQ activity but his activities in learning Chinese don’t interest me much.

In general though, I love it! My list of friends was getting unwieldly because it included Russian natives, Russian learners, English natives and English learners. Nice to be able to filter them.

thank you for the shortcut buttons in flashcards.
I would suggest to make the colour of the “term” a bit more dark (dark blue)

On the “rankings” tab, when you select some tutoring activity like “Conversation hosted” / “Writings corrected” filter by language select learners of this language, not tutors.
For example
Writings corrected, Japanese:
dooo 102
steve 55
mark 50
Jezsh 30
Harb 1

by the way, why is the secondary navigation bar (white one) not aligned with the first? It is a little fastidious to see

So, according to the rankings tab, Steve has 42 000 Lingqs. Presumably this is lingqs learned, not known words…or is it lingqs created?

As to the filters on the Friends page, I think these are wonderful, and very useful. But I think we will need to set that filter every time we come in to the page again. Is that correct? I wish there were a way to set that filter more permanently in our site settings/preferences page, so that whenever we come to the Friends page, we see the freinds page set up the way we wish to see it. And I would like to also see the site settings/preferences page give us the ability to set our flashcards preferences too so that when we come to the flashcards area we are ready to go, and don’t have to think about how we like to have things set.

I echo the concern expressed above about the activity tabs. When I look at the stats for those studying French, it would be ideal if I were to see their LingQs number for FRENCH lingQs only, rather than for all languages.

On that point, when I look at a friends profile, I see only a max of two tabs which give me their language stats. But that person may be studying multiple languages, chinese, russian and french, for example. No matter how many langs they study, I can only seem to see two language stat tabs at a time, and I don’t seem to be able to control which ones I get to see. I would love to see all the languages a friend is studying, all at once, if that is possible.

I do keep having trouble with my mouse hitting a very large field at the top of the page which blanks out the top of the page with dark blue, in order to give access to all the languages. I hit that field inadvertently over and over again, which means I can’t see what is under it, until I go through machinations to move my mouse out of that field and click elsewhere. I do wish that field could be significantly smaller or shorter or narrower or something.

LingQs are LingQs created, Helen. That is , to me, the key statistic. That is the measure of your activity. The rest will take care of itself.

Yes there are issues to resolve. Knowitsome thanks for the detailed report.

@SanneT - The flashcard popup is there but is probably hidden behind your main browser window. Try minimizing the browser window to see it. We will get it to pop to the front.

@nobuo - We will try again to get rid of the flashing.

@skyblueteapot - We will try and refine those results to only show activities in the selected language. But you have to promise not to hurt any of the other members…

@cakypa - You’re right, it is showing learners of the language and then listing their corrections or conversations hosted numbers in all languages. We’ll get that fixed.

@adelbertolito - That is a stylistic thing which has always been like that. You can take it up with our designer. :wink:

@KnowItSome - We will have your last filters remembered on the Friends page shortly. The change language popup was changed. You may have to refresh the page a few times to stop that funny behaviour. It does pop open on mouse over now though if you go too high when trying to hit the menu bar. This was done because we had people who couldn’t figure out how to change languages and we wanted to make it more obvious. You should be able to see all tabs for active languages in other members’ profiles. If you go to Steve’s profile, for instance, you can see he has 4 active languages.

Well, I’ve given my browser a good shake down (FF), there’s nothing hiding behind it. Just now I pasted the vocab learning link from the e-mail and was taken to the secondary sign in page and from there straight into my Spanish main page (and the url changed again, as described above, to Login - LingQ.

The only unusual thing in my setting is that I have been using the Swedish interface at the moment. Could that be the culprit?

I shall change to English in a moment to test my theory once I’ve posted this and shall report back whether it did the trick or not.

No, changing to the English interface didn’t solve the problem of my missing flashcards (I logged out after I had changed interface language and I refreshed the page a few times afterwards - don’t know what else to do).

Quite funny really, before the change to the new ones I hadn’t bothered using flashcards/learning vocab for quite some time!

The same thing happened to me that happened to SanneT. When I click on the email link, it goes to the main page, with the Login - LingQ url.