After not using lingq for a few months I’m starting to get back into it.
I don’t know what the issue is but LingQing has been very buggy and painfully slow/annoying to do. I’m having a few problems:

  1. Its slow. Putting the cursor over yellow, blue or underlined words doesn’t pop up instantly as it used to.
  2. Sometimes a yellow highlighted word wont pop up the window at all when i go over it. I then have to click somewhere around the text and then try again . Sometimes this fixes it sometimes not.
  3. Sometimes when i want to make a new lingq as soon as i bring down the mouse cursor to click the dictionary box the whole box just disappears. Its extremely sensitive.
  4. Word boxes seem to get stuck and not disappear like they should.
  5. I have to refresh the lesson I’m on many times.

Perhaps its my computer’s setup fault… I don’t remember lingq being this buggy however I am using lingq on a newer computer that i bought here in Korea.

I currently use windows 7 with firefox. My computer is up to date with all the latest updates for every program including , java, all browsers , all newest windows update etc… The computer itself is extremely fast using a really fast internet connection. Before anyone says to change Browsers. I’ve tried the newest IE and Google chrome and I still have the same laggy, buggy issues…



I’m not sure when the last time you were on the site was, but we removed the delay completely at one point then added it back again, since with no delay the popups appeared too quickly so multiple popups were visible at the same time.

You might want to try the new setting(s) at the bottom of the Settings page. This will make it so that you don’t need to hover back and forth over words, but can simply open them with a click.

When trying to click on the dictionary box, are you clicking on the actual line where it says “Search Dictionary” or are you overshooting and going below the popup?

I must say that I find the Lesson page working better than ever. The automatic loading of the google translate Hint, and the text to speech functions are great, and everything works smoothly for me, most of the time. Mac in FF.

@ Alex, Thanks, I’ll test out that new setting you’re talking about. However, It would be nice if i could get the hovering over the word to work as good as it seems to be working on steves computer =p because i like the hovering of words, it just doesn’t work well for me =(. I don’t mind a small delay in popups but the issues i’m having is either the popup takes up to 5 seconds + to show up or some popups don’t show up at alll… You can understand why that can be slightly annoying. As for the dictionary box , When the popup disappears I Cant even reach the dictionary line. I know if the mouse goes off the popup area it will disappear but my cursor is still on the box as i move it down to the dictionary line when it disappears. Its very weird… What about popup boxes that are stuck on the screen and wont go away no matter what?? I’ll test out the clicking setting but i really wish i could get the hovering over words to work without it being buggy.

@Steve I’m happy to hear it works extremely well for you. Not the case for me =p. Is there a Text to speech function in lingq now? Where is it?

To be clear, The system works like 75% of the time but there’s a 25% of time where the above bugs happen to me and that 25% of time is enough to drive me nuts =p. I wouldn’t have mentioned anything if those things only happen once in a while but it seems to happen repeatedly …

Update, The clicking setting seems to work fine Although, i dont like how if you touch the popup ( even slightly ) with your cursor and then you go off it the window will disapear. Should just be locked there until you click the word again ,click anywhere else or click the next word… Clicking multiple words will just produce a mess of windows unless you reclick the word/ touch the previous window…

Anyways , Perhaps I will stick with the click for now since the hovering is definietely not working flawlessly for me. Maybe a future update will magically fix this problem as i seem to be the only one affected by this.

Text to speech, appears on blue hover, yellow hover, LingQ widget, flash card. Everywhere.

Hi Steve,

Perhaps I’m missing something but I have no clue where to look for this Text To speech. I dont see it anywhere. Here are some screenshots of what i see on a blue hover , yellow hover and int he flash card window.


Also, What do you mean by LingQ widget? do you mean the lingq app on the iphone?

Sorry if all this is obvious but i just dont see any of it.

Maybe thats why my hovering over words isnt working well??

I am sorry. We rely on google for text to speech and it is not working for Korean. I will try to find out why. All the rest of the functions work just fine for me in Korean, Mac with FF.

Gotcha, Text to speech doesnt work in korean on Lingq. Thats fine… I don’t think thats an option i will use much anyways… I was just curious where the option was because i really couldn’t find it anywhere. thought maybe something was wrong with me computer…

I’ve been using Alex’s suggestion for the click setting. I actually like it ( minus the things i pointed a few posts up) The blue words pop up right away when i hover over them ( which wasn’t the case before). I think I will be using this method from now on unless the hovering method gets fixed on my computer somehow.


If possible, can you take a screencast to show exactly what you’re experiencing in the hover mode? You can use a program like Jing to record a screencast.

Cool… I’ll look into Jing if the buggyness bothers me again. I think for now I’ll keep it setup to clicks on yellow highlighted words instead of hovering. ITs growing on me…

FireFox 5 just came out and I just updated. Seems like all the buggyness disapeared… No need to refresh the page anymore. Yellow hovers show up right away…


glad to hear your problems are resolved.

HI Alex,

Ok soo updating my firefox seems to have taken away the Lagging issue i was having before.

HOWEVER here’s a problem i can recreate nearly 90% of the time. It happens when I select multiple words to create a new LingQ. Watch the video HERE: ( skip to the 20 second mark)


As I said, It happens almost every single time. I can create 10 more videos showing this if you like. =p.

If its not clear from the video heres whats going on.

I select 2 words to make a blue highlight. As you can see I put my mouse over it and the popup doesnt show up.
I take the mouse off having to click on away ( you can see i click with the ripple. i click because if i went back without clicking the window wont pop up). After i create my lingq the window does no go away. No matter where i click and what i do it just sits there. Although i could just ignore this, but as you can see i cant see the text that’s covered and if i move on and select an other batch of words the same thing will happen. soo I have to refresh the page.

I hope you can see why this could be frustrating a little bit. I dont lingq multiple words/sentences tooo too much but when i do this is what happens…

Anyone else having this issue?

We have had some reports of this error and are currently looking at it. Thank you very much for the video (it is immensely helpful!).

Hi keroro,

We’ve just made a few changes that should resolve this issue. I tested and it seems to be working fine now, but you must refresh the page first. Can you give it another test and see if you’re still experiencing this problem?

Hi Alex, I just tested it on a couple of lines and everythign seemed to be working well and then i just tried it again and the popup froze once again. It doesnt seem to be happening as much as before though But i will have to keep you posted! Need to test it out more…

Hi keroro,

Just wondering if you’re still experiencing this problem or not. We want to make sure it’s taken care of :slight_smile: