Bookmarklet didn't work with pictures

I tried to import the following wikipedia page but the bookmarklet didn’t work. Just nothing happened. I deleted and reinstalled the bookmarklet, but got the same result. I now find that when I select text only, it works. But when I have to select pictures etc, because I want to import more than one paragraph at a time, it doesn’t work.

I had a similiar problem importing from “One Thing in a French Day”. I had to give up trying to import multiple posts at once.

I didn’t have any trouble importing all of the text on the webpage in question. Try again and make sure to click the Import Bookmarklet again if nothing happens the first time you click it. Also, if you can find another page that isn’t working with the Import Bookmarklet please let us know.

I tried it again, this time with Chrome (before, I was using FF) and on a different computer, and it still didn’t work.

It appears there is some sort of glitch, but it is dependent on which portion of the text you select. If you select everything from “2月16日に” at the top to “(青空文庫)” at the bottom then it works fine. If you exclude these two lines nothing happens. However, if you simply exclude the title line that says “よだかの星” it works fine, and the title of the page automatically becomes the title of the lesson.

We’ll take a look at why this error is occurring and see if we can get it to work properly.

The bookmarklet doesn’t seem to work in the least on Chrome. I see the following error in the console:

Uncaught SyntaxError: Unexpected token %

This is a known issue, but it is actually on Chrome’s end. They seem to have fixed the issue in some development versions, so it hopefully shouldn’t be too long until the fix makes it to the public version of Chrome.

For now you’ll have to either manually import lessons or use another browser when using the Import Bookmarklet.