App crashes 10+ times a day

My Android app crashes many times a day during months. It does not help to clean the audio cache or to reboot the phone. The audio may have tiny pauses, it is almost impossible to listen to the end of audio if it is longer than 20 minutes.
Another issue: sometimes it shows no lessons at all on swithching languages. The solution is to switch to any other language and trying again. It can take 5 or more attempts.
Samsung Galaxy S10, Android version 12


Not sure if it is this, but you might check:

If you’re on android you may need to make sure the app will run in the background. On the later versions of android there may be battery efficiency settings that will essentially stop an app running in the background to save on battery.

If you are using Android, and it is “vanilla” android here are the steps (if using Samsung, or other android phone the setting names might be different).

Go to settings->apps->app battery usage. Make sure “all apps” listed. Find LingQ app. Make sure “Allow background usage” is on. Also click on the text of this setting. Here you’ll see some more specific settings. One optimized and one Unrestricted. If having just the “allow background usage” doesn’t help, then you might further select the “unrestricted” setting.


Thank you for the reply. I tried to play with the phone settings. The problem can occur even when the app is the only one open app, I can hear the degradation of the audio, how it stops and plays itself more and more until it stops completely. Thereafter the app may be frozen and than it may disappear at all.
The phone shows it found a problematic app which crashed.
As I said, it happens every day many times even for very short lessons.
The app was updated some days ago.


Just a silly thing to try. Have you tried deleting the app completely, including any backup you have on the cloud, if you have any, and download it again? Restarting from scratch? You don’t lose anything a part from the downloaded playlists, and a few dedicated settings.

Have you check if the same thing is occurring with new downloaded lessons? It could be an old corrupted file that is creating this.

I don’t know the Android system, so I have no idea what other advice could be helpful.


Sorry to hear that @Ress . Do you have any idea when did it start happening?


I deleted the app and reinstalled it again. The problem is gone. It seems I use the app too much :wink:


Glad to hear it! (that it works, not that you use it too much :smiley: )