API method to view text - 404

Is the API doc up to date? Some of the methods work, but I was not able to view the text for a lesson:

Even the provided example returned a 404 error:
curl ‘https://www.lingq.com/api/languages/en/35411/text/’ -H ‘Authorization: Token ’

And the same error when fetching sentences: /api/languages/en/85411/sentences/

Perhaps the URL changed for these methods?
Thanks for any help!

I don’t think Content Id 35411 exists anymore. Try 6710590. I know that one works

Edit: Yeah, maybe not. That doesn’t work either. Bedtime for me, I’ll play with this tomorrow

Thanks for the reply, spatterson. I can view the Lessons List for that id:

and Lesson Info for the first lesson in that list:

But I can’t view the text of that lesson! This URL returns a 404:

Is this API method documented incorrectly?

@slatterypod - I know there have been some updates to the API, though I don’t know if all of the changes have been documented yet. I will ask one of our developers about this!

Okay, they did change the API.

I was able to do this
curl ‘https://www.lingq.com/api/languages/en/lessons/’ -H “Authorization: Token $TOKEN”
to get some content_ids

curl ‘https://www.lingq.com/api/languages/en/lessons/12907/text/’ -H “Authorization: Token $TOKEN”

Edit: I don’t know why/how they’re getting these content ids. 6710590 should have worked… but it doesn’t

1 Like

Thanks spatterson, that’s a good find…