Android App: "Translate Sentence" button in sentence mode not always working

I imported an ebook in EPUB format and want to read it in sentence mode. Unfortunately it often appears that the “Translate Sentence” button is doing nothing.

I tap on the button and get no feedback at all.

It is not consistent, but most of the time it seems not to be working for longer sentences (>= 4 lines), but sometimes it also happens on shorter sentences.

For the same sentences of the same imported ebook, the button works fine in the WEB version.

I experienced this on two different Android smartphones (Realme 6 with Android 11 and Samsung Galaxy S7 with an older Android version).

LingQ Android app version is: v. 4.9.21 (284)

1 Like

Sorry to hear that. I asked our Android developers to check that.

1 Like

Maybe this helps for reproduction: I have encountered the same problem not only with imported Epub material, but also with a book from the LingQ library. It is in the Spanish version of “The little prince” (El principito), in chapter one after a few sentences.

See this screenshot:

Here i tapped on the “Translate Sentence” button, but nothing happened.

Sentence view translation in android app has never worked for me for any imported book. Probably is something about the formatting but not sure.

@holzscheit Thanks, we already had a same problems and reports before, we are looking into it.
In the meantime, would you be interested in joining the beta program and using the Beta Android app? If so, please contact me on support(at) and I’ll set you up.

I already joined the Beta and I am currently switching back and forth between version 4 and 5 (version 5 is great!).

I can say that this problem exists in both versions, so this is definitely something that should be fixed.

1 Like

I’ve used LingQ daily for about two years in multiple languages on both the computer (web version) and android phone. I reported this issue when I first started and it has always been like this - has never worked. Short sentences translate and long sentences never do on android - but work on the web. I was hoping that this would be fixed in the next upgrade of LingQ. Sorry, I know I am repeating what others already have said, but just to let everyone know that multiple people have seen and reported this issue.

1 Like

I have actually found it to be much better in the new app…and interestingly better in the old app recently. Still, you are correct, it doesn’t work so well with longer sentences. Hopefully it can get even better, but I feel there’s been progress here.

I’ve been waiting for some time for this to be fixed.
I wonder why the team are happy to leave it like this - broken.
It’s not very impressive for what is supposed to be a professional outfit.
Is it?
Also, there should be a choice of which service does the translation. Deepl is MUCH than Google, for example…