A few TTS issues

  1. I was surprised to find no TTS for the Traditional Chinese slot.
  2. Malay also has no TTS now, though it used to use Indonesian TTS when I was studying it here last year. Would it be easy to flip this back on?
  3. I’m having a weird issue, at least in Chrome (couldn’t reproduce in Edge just now), where sometimes I will hit “S” on a word (to hear the TTS) and no matter how many times I press it, it just won’t play any sound. And then I move to the next word, and it plays that word (because I have auto-read on) as well as, simultaneously, a chorus of readings of the word I had failed to get read to me before. It’s like at some point the site started to buffer my requests to hear the sound, and could have started playing it, but instead held onto it until the next word was selected. Does anybody else experience this?


Yes, I have the problem you mentioned in 3., too. Actually, in the past, it worked just fine, but then it often didn’t play the word, I hit shift (when reviewing vocab) and then the whole mess starts. It really makes LingQ almost unusuable at times.

1 Like

Thanks @Miznia!
1 and 2) I reported Traditional Chinese TTS issue to our team and we will get it fixed. We will see if we can add Indonesian TTS for Malay again.
3) I’ll look into this too and try to reproduce it. We will get it fixed.

Thanks again for your feedback.

1 Like

Here’s a weird one, really minor issue, but maybe this info will help debug something. If you go to Hungarian Mini Story #14, and get TTS for the word on line 2 “táncolni” (“to dance”) it plays the TTS for the word on the next line “táncórájára” (“to her dance lesson”). I was able to reproduce this by creating a one-word lesson with just the word táncolni and even this sounded like táncórájára even though the latter word isn’t in that lesson. Isn’t that very strange?

Are there any news about that?

I’ve had number 3 happen too. I’m also getting the wrong word read out sometimes when it does work. Not sure what the best way is to update the devs on cases where it’s not working/reads out the wrong word. I’m using Firefox 70.0.

I reported this to our developers back when this thread was created. I will post update here as soon as I hear back from them.

1 Like

After the last Update the TTS for Spanish worked just fine for a couple of days ,but now every now and then it stops working and I have to close the App and sometimes even deinstall it! Does anyone else have the same problem. And Zoran, could you report this to the developers. I´m using the android App

@Mpampalitsas Do you have Googe TTS installed and set as default on your device?

I am having the same problem with Russian. I am often getting read out the wrong word when using the flashcards to review. That is annoying.


I get the same thing on the web version, it comes and goes, have to completely kill my browser to get tts back

Thanks. We will investigate that further. If it worked fine for a few days after you updated the app, that means that the issue probably isn’t with the app, otherwise the issues would be appearing right after updating.