3 problems LinQing in Chinese

I recently installed the import bookmarklet into my bookmarks toolbar and it seems to work for other languages apart from Chinese. I get the message “Type matching query does not exist.” Everytime I try to upload some Chinese text (uploading English or Japanese works fine). I’ve tried it with different browsers and I still get the same message.

A slightly more annoying problem is the automatic dictionary search function seems to have broken down. When I hit ‘new hint’ it used to automatically search youdao or nciku or whichever dictionary I had set it to, and a fresh window would pop-up with my search completed. This was great, but now I just get “Nothing found, sorry” under dictionary settings, and have to manually search for the word. I get the feeling this might be something I’ve done, but I can’t seem to figure out what it is.

My final query is about the highlighting of words in Chinese. When a new article is uploaded, the highlighting of the characters is a bit random. Sometimes 5 characters in a row are highlighted together, othertimes just one character will be selected when the character next to it combines to make a fairly common word. This wouldn’t be too much of a problem except that when the highlighted section is deleted— either through ‘knowing’ the word, or deleting the linq—I am then unable to select the correct combination of characters to link the correct word. The computer always wants to select the original combination of characters, and won’t let me get round this. This can be pretty frustrating, and I haven’t really come up with a good way round it.

Anybody having the same issues? I’d really appreciate any suggestions/help regarding these things!

Thanks, ありがとう、谢谢!

Hi Neiru,

The first one is definitely a glitch on our side. We hope to get it sorted out shortly.

The second issue you mention is a recent bug, but nothing that you’ve done wrong. It’s an issue with the dictionary automatically appearing. We’re working on this one now.

The third is likely related to our algorithm that splits Chinese text into separate “words”, as there are no natural spaces in the language. When we have a chance we’ll continue to refine this algorithm, but since this is the case with private lessons you can edit the lesson and manually correct the spacing or simply create a LingQ of the word or phrase that you’re looking to save.

Thanks for reporting these things! We continue to work on fixes for them, so hopefully it won’t be too much longer!

OK Alex,

Thanks for getting back to me about these. Hope you manage to get them sorted out soon.

Cheers, Neiru.

The second issue has been fixed – we’re still working on the first one though. Thanks for your patience!

The first issue has also now been fixed. Sorry for the delay. Enjoy your Chinese studies!

Hi Alex,

I’m also experiencing the third issue that Neiru mentioned. I’m actually quite amazed with how good the algorithm already works, but understandably there are a few errors from time to time. I can imagine the algorithm is rather complex, but if there was an easy way to correct the wrong groupings manually, it would already be very helpful. If I understand correctly what you are proposing is to add the spaces manually in the uploaded text, which is rather cumbersome. It would be much easier if we could simply mark the word as known and select the right combination (without the origal group being selected automatically).
I don’t know if that is technically easy to accomplish, but maybe easier than improving the algorithm itself?

Thanks, Stef.

Hi Stef,

We’ll have to look into this to see how difficult and practical this might be. Thanks for the suggestion.

Ok thanks.

Thanks for fixing those. The import bookmarklet and the automatic dictionary are working well now.

I’m afraid I have a couple of new problems to report now though.

Firstly, is the “know all unknown words” prompt that pops up every time you try to navigate away from a lesson a new feature? I haven’t noticed it before, but now it pops up every time I try to navigate away from a lesson. I’ve checked the “don’t show this again” box again and again, but it still pops up. It’s pretty annoying, and I just accidentally “knew” all the words in a lesson that I didn’t want to “know”, just because I wasn’t paying attention when it poped up again. Not sure if I can undo that now. I’m wondering if this feature is really necessary? And if it is, can you make it so that it goes away when you ask it to?

Secondly, it appears that when I create new lingQs, especially longer combinations, like phrases or sentences, these are not remembered when I return to the lesson. This can be quite frustrating. If I try to recreate the lingQ, the information I previously entered in the definition field is still there making it easy to recreate, but if I navigate away from the lesson and come back later the lingQ has gone again.

Thanks for your attention to these issues.

@Neiru - We do apologize for these issues with the “LingQ’d” popup. We will get them fixed as soon as we can.

Ok, thanks.

I disabled the Lingq’d button, but now I can’t find the “I know all” button. Is there and way to get either button back?

Ok I found the LingQ’d button at the bottom of the lesson, but it doesn’t seem to work. Using FF 3.6.13

We have pushed a couple fixes to the site today. The “Do not show…” link on the LingQ’d popup should now be working so you can turn that popup off forever. You may have to push it a few times and/or refresh before the cache is cleaned out and it works. Hope this helps.

Great! It took a couple of goes, and I also cleaned out the cache on my computer, so it’s gone now. Thanks.