Translation Problem

My native language is English, but the blue and yellow highlighted words are still showing the foreign words when I click on them, rather than the English translation. How do I reset this?

You can change your dictionary language to English under the settings button (gear icon) on the home page. Reader Settings tab in the settings popup.